It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I installed Barony on Win7 and tried to run it, but it keeps returning a "The program can't start because MSVCP140.dll is missing from your computer." Is something missing from the GOG installer? Is there any way to fix this?

I've attached a screenshot of the error.
Post edited December 03, 2016 by IronArcturus
No posts in this topic were marked as the solution yet. If you can help, add your reply
It looks like a possible solution to this problem is installing the 32-bit version of " Visual C++ Redistributable for Visual Studio 2015."
This happened to me yesterday. After installing River City Ransom and Iconoclasts (both GOG games) on the same machine (64bit Win 8.1), one of those games must have messed with some of my Visual C++ libraries, and both Barony and Iconoclasts refused to launch showing this same error message.

Funny thing was MSVCP140.dll was present in both my "System32" and "SysWOW64" folders, so it probably got corrupted.

To solve this, I downloaded and installed both x86 and x64 versions of the latest build of Visual C++ 2015, from the Microsoft official website:

There are lots of Visual C++ versions, we need the 2015 version because MSVCP140.dll belongs specifically to the 2015 one. If you want to know which Visual C++ version does a specific dll belong to, find that dll file on your System32 folder, right-click it and check its Properties > Details.

Then I uninstalled Barony and Iconoclasts, restarted Windows, and installed them again.

After that, Barony works fine. Iconoclasts still shows the error when starting, but then works fine. I may have still some older corrupted Visual C++ libraries somewhere, but I'm too afraid to delete older libraries, in case it gets worse.

The internet is full of Visual C++ troubleshooting that recommends to run virus scans, go into Safe Mode or launch the command "sfc /scannow". None of these worked.
Post edited May 09, 2018 by Hollyhock