It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I have a 22 inch monitor, can anyone tell me how I can play it on there at a playable size? For I have found that most widescreen mods seem to require BG2.
This question / problem has been solved by WyE5JZhXEXimage
According to the Widescreen Mod's description:

"The Widescreen Mod allows Planescape:Torment, Baldur's Gate: Tales of the sword Coast, Baldur's Gate II: Shadows of Amn, Baldur's Gate II: Throne of Bhaal, Icewind Dale: Heart of Winter and Icewind Dale II to be played at previously unsupported resolutions, like those of widescreen monitors."

You should use the GUI Mod as well for best results. Make sure you install the widescreen mod at one of the resolutions supported by the GUI mod.
Post edited October 31, 2010 by xenobrain
It informs me that it cannot find "Chitin.key" when it is right next to the widescreen installer. D:

Am I missing something stupid here?
Post edited November 01, 2010 by DefiantBadger
Look at this:
Read and follow instructions carefully. I also have a 22 inch monitor, works flawlessly.
Looks like this (1280X800):
Well I installed it and it and the GUI mod, yet it still doesn't work as it should. The image is all compressed to one corner (Yes, I did pick the right resoulution, 1280 by 800) and it isn't the true colours and has strips of black through it. When I exit it through the menu it then says "An assertion failed in D:\Dev\Baldur\ChUI.cpp at line number 773".

Could anyone help me or point me to someone or thing that could?
If the image is off in a corner it means the GUI mod didn't install correctly, because that is one of the things it fixes.

Did you run the GUI mod's setup program? In the .rar file you downloaded, there's an executable which you point to the BG game directory. It's just an unpacker though, you still have to run something called, I think "TWM_GUI_Mod_Setup" (I didn't that right but hopefully close enough) from the BG game directory.

Lastly, BG1 defaults to 16-bit color, you have to change that in the game options menu which is only available once you have started or loaded a game (lame, I know).

Hope something in there helps.
Post edited November 04, 2010 by xenobrain
Ok, I have done that; except now I can't even start BG, with it stating:

"An Assertion failed in D:\Dev\chitin\CHVideo.cpp at line number 4156
Programmer says: No valid video modes supported."

Halp! D:
I recognise this error - I originally chose 1280x800 for the widescreen mod because that is what my laptop runs at and it's also compatible with the TWM_GUI mod. It worked fine until I connected a large external screen to my laptop - both my old 21 inch 4:3 and my new 24 inch 16:10 screens gave EXACTLY the same error you quote, because neither of them support that resolution (I just tried it again to be certain). I had to re-install the widescreen mod and choose 1280x768, which is supported both by my laptop's own screen and also my large external monitor (and TWM_GUI).

Come to think of it, I suppose it's because I'm using the default Windows XP Plug and Play driver, which doesn't list 1280x800 as a valid mode. I don't want to install the screen manufactures drivers on the laptop, so I'll have to wait until I try it on a PC sometime, to see if it offers 1280x800 as a valid mode, which the TWM_GUI mod Readme suggests it should for 16:10 screens.

But anyway, try setting the widescreen mod to 1280x768 if you haven't already.

I have my fingers crossed for you.
I have installed it at 1280x768 and it seems to work quite well. However it still cuts off a bit of the Hud while ingame and the menu is squashed to the centre.

While it's still playable, it isn't particularly Ideal. The Hud being cut off is the biggest problem, is there anything else I could do? :o
Post edited November 06, 2010 by DefiantBadger
Not too sure what you mean - which part of the HUD is missing? Could you post a screenshot? Anyway, here's a couple of thoughts, however unlikely they sound:-

1) Is it possible the monitor just needs adjusting to display the whole screen in this mode, even though it works fine in other modes?

2) Maybe the patching process of the mods didn't work properly or, bearing in mind your earlier comments, something happened subsequently. If it were me, I would uninstall the widescreen mod and the game, ensuring the Baldurs Gate folder is removed as well, then re-install the game and mods from scratch. A bit of a pain, but you may find it is worth it .

As for the squashed menu, again it depends exactly what you mean, but if it is like the attached screenshot, then that is normal. The mods only affect the playing screen, not the menu screens. If you mean something else, then again, a screenshot may possibly suggest a cause.
menu.jpg (203 Kb)
Ah it would appear it was just my monitor. I was too willing to believe that it would be something wrong with the installation of the mod rather than something like that.

Anywho, many thanks for your help it was most appreciated :D
yo! having a bit of a problem, i installed widescreen mod and the gui interface bit, when i play baldur's gate, it goes through the beginning cinematics but once it hits the beginning interface of New Game and such, i get an error code

An assertion failed in
D:\Dev\Baldur\chUIControls.cpp at line number 488

any help dudes?
There is no setup.exe in the GUI mod folder, just a .tp2. How do I use the gui mod?
allenor1: There is no setup.exe in the GUI mod folder, just a .tp2. How do I use the gui mod?
Setup was probably extracted to game main folder.