It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I've Noticed that both BG1 and 2 are very slow when saving. It used to be almost instantaineous, especially quick-saving.

Any ideas?

Thanks
avatar
notrog: I've Noticed that both BG1 and 2 are very slow when saving. It used to be almost instantaineous, especially quick-saving.
It's a weird OpenGL bug. You can switch to alternate renderer which will speed up the save process but will slow movement speed to a crawl and may make sound wonky.

There was a thread on reddit about it where Beamdog's marketting monkey told the person to file a bug about it.

Not sure if the bug was filed so if you want to deal with Beamdog's spam filter you can file one at support.baldursgate.com
think its normal behavior... noticed while playing SoD ... the saving was quick in the beginning.. but took longer time further into the game
Hey there

It's just because you have alot of saves in your save folder. Try to cut as many saves as you can from the save directory and try again.

Save location of original BG: Game directory, save folder
Save location of BG:EE: C:\Users\username\Documents\Baldur's Gate - Enhanced Edition\save

It's because of the ammount of data in the folder. That's why it's fast at the beginning of the game and goes slower as you progress and save more.

Regards
O
Hi guys.

After some investigation, it seems to be a problem with the latest 2.5 patch rather than the number of savegames. I don't have the same problem with earlier versions. Will post this in the relevant forum, see if anyone else has come across this.

Cheers,

Notrog
I've got the same problem and I have only about 7 saves, and I'm at the very start of the game (finishing Nashkeel).

Solution:

Here it is (it is not my solution, I've jest copied it from BeamDog forums, all thanks to: Gusinda)

"- Download OpenGL32.dll (32Bit) driver, unpack and copy into the root of the game folder (where Baldur.exe lives)
- run the game in OpenGL mode [I've just normally launched it trough gog galaxy - Blutok]
- Test saved game, quicksave and named, and transtion between areas. Hopefully it all runs smoothly!"

AS for me I needed to use 'Alternative Render' mode in graphic options to run the game smoothly after this operation, for now everything works perfect :-)
Post edited December 19, 2018 by blutok