It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi guys, as the title indicates, I have no sound at all for either BG2:EE or IWD:EE on my 64 bit 15.04 (3.19.0-13 kernel). Any ideas to fix this problem would be most welcome. I copy the console log after running IWD below.

INFO: Creating DPWrapper
INFO: scanning:(18) /home/pedro/GOG Games/Icewind Dale Enhanced Edition/game/override
INFO: scanning:(16) /home/pedro/GOG Games/Icewind Dale Enhanced Edition/game/scripts
INFO: scanning:(15) /home/pedro/GOG Games/Icewind Dale Enhanced Edition/game/sounds
INFO: scanning:(13) /home/pedro/GOG Games/Icewind Dale Enhanced Edition/game/lang/en_US/sounds
INFO: scanning:(11) /home/pedro/GOG Games/Icewind Dale Enhanced Edition/game/portraits
INFO: scanning:(10) /home/pedro/GOG Games/Icewind Dale Enhanced Edition/game/characters
INFO: scanning:(9) /home/pedro/GOG Games/Icewind Dale Enhanced Edition/game/movies
INFO: scanning:(8) /home/pedro/GOG Games/Icewind Dale Enhanced Edition/game/lang/en_US/movies
INFO: scanning:(6) /home/pedro/.local/share/Icewind Dale - Enhanced Edition/override
INFO: scanning:(5) /home/pedro/.local/share/Icewind Dale - Enhanced Edition/scripts
INFO: scanning:(4) /home/pedro/.local/share/Icewind Dale - Enhanced Edition/sounds
INFO: scanning:(3) /home/pedro/.local/share/Icewind Dale - Enhanced Edition/portraits
INFO: scanning:(2) /home/pedro/.local/share/Icewind Dale - Enhanced Edition/characters
INFO: scanning:(1) /home/pedro/.local/share/Icewind Dale - Enhanced Edition/movies
INFO: gl.useShaders: 1
gl.has_s3tc: 1
gl.has_pvrtc: 0
gl.has_atc: 0
gl.postprocessing: 1
gl.uploadFormat: 0x80E1
gl.uploadType: 0x8367
INFO: Icewind Dale - Enhanced Edition v1, 4.0
AL lib: ReleaseALC: 1 device not closed
No posts in this topic were marked as the solution yet. If you can help, add your reply
Did you ever find a fix for this? I am having the same issue with BG:EE. I made sure libasound2 was installed like the support page suggests but no dice.
Did you install the 32bit sound libraries or only the 64bit ones?
The 32bit ones were but the 64bit ones weren't?? So it works now, thank you for pointing me in the right direction.
I'm having this issue too with IWD:EE. What is strange is that BG/2:EE work fine for me through Steam, but IWD:EE installed through GoG has no sound. I don't use the steam runtime either, so I have all the native libs for BG. I do have openal 32 and 64 bit libraries and the pulseaudio alsa plugins in both 32 and 64 bit format but no sound in game and only

AL lib: (EE) alc_cleanup: 1 device not close

as any line from running start.sh of anything to do with audio.

Edit: Turns out IWD:EE defaults to the first alphabetical sound card and trying to change its sink target in Pulse doesn't do anything. So if you don't get sound and its defaulting to anything but your actual default sound device disable everything else and it should work when you start it again.
Post edited March 07, 2018 by LordZanny