It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Mornagest: OK thank you for your very useful answer.......

I downloaded BGEE yesterday evening and I'm not bash-expert.

And since clicking on the BGEE icon in the main menu doesn't do anything, I cannot see any other way to launch the game but that script.

If you have any real answer to give, I'm opened to suggestions.
who said it's an expert thing to run an executable with an env var in front of it???

cd <path_to_bg>/game
mkdir mylib
get older openssl for you distro at
cp <openssl_libs> mylibs
LD_LIBRARY_PATH=mylib ./BaldursGate

leaving it for your exercise to make it work with the .desktop launcher...
Well, "expert" was an allegory but I'm not accustomed with script manipulations and I guess I'm not supposed to be just because I run on Linux.

On the post I linked above it is written that you have to replace a line by another, and since the mentioned line doesn't exist anymore, and since not everyone is supposed to know where to put the lib variable... well, I hope you understand.

I asked Vv221 who answered me and linked me to this page:
If you have Steam you may not need to install anything else to solve it.

My fix for this issue by adding this library from the steam runtime (yes for the GOG version) to the LD_PRELOAD.
Just add this line at the start of the file:

export LD_PRELOAD=~/.steam/bin/steam-runtime/lib/x86_64-linux-gnu/
If you have steam installed, then just add this on top of your file (or export it before you execute it).

export LD_LIBRARY_PATH=~/.steam/bin/steam-runtime/lib/x86_64-linux-gnu/
I had no sound when I used the solution from the post above, but what worked for me was:

1. copy" AND "" from ~/.steam/bin/steam-runtime/lib/x86_64-linux-gnu to ~/GOG Games/Baldurs Gate Enhanced Edition/game

2. add export LD_LIBRARY_PATH=~/GOG\ Games/Baldurs\ Gate\ Enhanced\ Edition/game/ on top of

Ubuntu 22.04

For some reason the libs were not loaded on their own and I had to add the path manually.
Seems the sound issue was caused by grabbing too many libraries from steam, but it's just a guess.