It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I have Baldur's gate I and II installed with the mods as instructed on the modding page here on gog. When I first installed it took me a while to figure out how to get the game to display stretched and fullscreen as it always kept aspect ratio regardless of resolution options outside of the game. Eventually I managed to stretch it, I think using a command in the right click properties menu?
I have just reinstalled the games and I have searched high and low on the internet for a way to stretch to fullscreen but nothing seems to work. Does anyone know what that command might have been or have another solution?

I have tried changing my desktop resolution and selecting stretch. I am using a laptop with AMD HD 7600m series. There is no enable scaling option for when I am not connected to an external display. I have tried the enable gpu scaling option while connected to my tv with no improvement.
This question / problem has been solved by DeMignonimage
avatar
evitome: (snip)
Why do you want to stretch it, the picture will look distorted and blurry. You can use the Widescreen Mod to run both games in widescreen resolution (e.g. the same resolution as your desktop).

Download:
http://www.gibberlings3.net/widescreen/

Installation:
The Widescreen mod is distributed as a self-extracting archive. To install, simply double-click the archive and follow the instructions on screen.

Alternatively the files can be extracted from the archive using WinRAR or 7-Zip. If properly extracted, you should have a widescreen folder and setup-widescreen.exe in your game folder. To install, simply double-click setup-widescreen.exe and follow the instructions on screen.

Please run setup-widescreen.exe in your game folder to reinstall, uninstall or otherwise change settings.
Post edited November 19, 2013 by DeMignon
I have used the widescreen mod, but previously I was able to select 1024x768 and get both the menus and the game to stretch to full screen which I much preferred. I am not a fan of the little menus or the fact that using a bigger font covers characters while they speak and takes up more room at the bottom of the game screen.

I think the command I was looking for tells the game not to scale itself but to follow my desktop? I am afraid I am unsure as I am not really a modder.
I see.
BG itself runs in the the resolution you tell it to. The stretching of an 4:3 aspect ratio (e.g. 1024x768) to widescreen is done later by your graphics card, if you tell it to. So you have to look in your graphics card settings for this option.
Your AMD HD7600 probably uses the Catalyst Control Center for configuration (look for Scale Image to Full Panel Size). Here is a how-to with pics from AMD support:
http://support.amd.com/en-us/kb-articles/Pages/UnableToSetGPUScaling.aspx

As you have made changes while right-clicking the start icon of the game, make sure your don't force the program to use a 640x480 resolution. (Right-click the start icon => Properties => Compatibility => uncheck 640x480 resolution)

I'd still try to run it in real widescreen, rather than stretched. A resolution of 1366x768 or 1368x768 would be of the same size (also same font size) as your 1024x768, just extended to the sides. Whether these resolutions work or not, depends on whether your graphics card is able to display them in fullscreen or not (windowed mode should always work).
Post edited November 19, 2013 by DeMignon
avatar
DeMignon: I see.
BG itself runs in the the resolution you tell it to. The stretching of an 4:3 aspect ratio (e.g. 1024x768) to widescreen is done later by your graphics card, if you tell it to. So you have to look in your graphics card settings for this option.
Your AMD HD7600 probably uses the Catalyst Control Center for configuration (look for Scale Image to Full Panel Size). Here is a how-to with pics from AMD support:
http://support.amd.com/en-us/kb-articles/Pages/UnableToSetGPUScaling.aspx

As you have made changes while right-clicking the start icon of the game, make sure your don't force the program to use a 640x480 resolution. (Right-click the start icon => Properties => Compatibility => uncheck 640x480 resolution)

I'd still try to run it in real widescreen, rather than stretched. A resolution of 1366x768 or 1368x768 would be of the same size (also same font size) as your 1024x768, just extended to the sides. Whether these resolutions work or not, depends on whether your graphics card is able to display them in fullscreen or not (windowed mode should always work).
Thanks for the suggestion but I have tried that, I am unable to scale the image on my laptop, it only works for external displays. If I am not connected to my TV for example there is no scaling option available.
This looks like a glitch in the AMD/ATI graphics card configuration. It seems, they grey out the options for scaling, when you use the optimal native resolution of your laptop display. I've no idea, who implements things like these ;-)
Try lowering your desktop resolution (preferably to a smaller widescreen format) and check if the scaling options are accessible now. If so, turn scaling on and try running BG. If that works, you can try going back to your optimal desktop resolution and hope the scaling option still applies.
Post edited November 19, 2013 by DeMignon
avatar
DeMignon: This looks like a glitch in the AMD/ATI graphics card configuration. It seems, they grey out the options for scaling, when you use the optimal native resolution of your laptop display. I've no idea, who implements things like these ;-)
Try lowering your desktop resolution (preferably to a smaller widescreen format) and check if the scaling options are accessible now. If so, turn scaling on and try running BG. If that works, you can try going back to your optimal desktop resolution and hope the scaling option still applies.
No luck but I can turn down the resolution and play in windowed mode ( if I leave windowed mode it shrinks and the black borders reappear). I guess that will have to do. Thanks for the help :)
So, turns out the playing in windowed mode at a lower resolution was also no good as parts of the game screen are intermittently cut off. If anyone has any further ideas they would be much appreciated.
Just to clarify, what's your current desktop resolution, what's the maximum supported and have you changed it to a lower value, yet?

What Windows version do you use?

Do you use the Catalyst Drivers and have you already updated them?
http://support.amd.com/de-de/download
avatar
DeMignon: Just to clarify, what's your current desktop resolution, what's the maximum supported and have you changed it to a lower value, yet?

What Windows version do you use?

Do you use the Catalyst Drivers and have you already updated them?
http://support.amd.com/de-de/download
The drivers are up to date, my screen resolution is 1600x900 (I have tried others though) and it is windows 8.1. I fear the update to windows 8.1 may have changed something although I was able to stretch to fullscreen under windows 8.
This might have nothing to do with the problem, because scaling is done by the graphics card, but you might want to install DirectX9. Windows 8.1 by default comes with DirectX11 and by installing DirectX9 your system will be complemented by older libraries from version 9. (Some older games won't even run without these).
Link to DirectX 9 Webinstaller: http://www.microsoft.com/en-us/download/details.aspx?id=35

Have you run setup-widescreen.exe in your game's folder to try the resolutions 1366x768 or 1368x768?
(Check if you could theoretically set your desktop to one of these. If they're offered in the display settings, your system should be able to use them)
Post edited November 20, 2013 by DeMignon
Not sure how but I seem to have fixed things while messing around with catalyst, thanks again for the help.