It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Ok I'm hoping SOMEONE might be able to help with this because I've searched and searched and can't seem to find a solution that works. So I got the anthology, me and my brother installed both games with the sword coast/throne of bhaal expansions, playing on the same home network, both Windows 7. The multiplayer for the first game works just fine, provided we use his computer as a host (For some reason we just couldn't connect to mine, no matter what I did with the firewalls etc. but at least we can play. Much as it bugs me to not be able to troubleshoot the issue lol.)

Then we thought we would try out 2. Using his IP since it worked for the first one. All our settings are the same, no one's firewalls are blocking anything. Then I go to connect to the game he created and get as far as "Enter Session Password' and I get a "Cannot connect' error. We're 100% positive the password was right (I mean we're sitting in the same room, looking at eachother's screens to make sure we don't mess anything up. I can only assume there was no issue with that.). I figure if we got that far, we MUST be at least connecting?

THEN we tried it without any password and now I'm just straight up getting a "Cannot Connect" error. It tries for a few minutes and then doesn't go through. We're both in windowed mode because it crashes otherwise and the single player works just fine so I don't think it's compatibility?

Also we tried that hamachi(sp?) thing when we were having issues with the first one and it didn't work (And I still can't explain WHY the first one actually started working but it does now every time without fail. Color me delightfully confused.) so I'm assuming it won't make any difference for the second? I'm not 100% clear on how it works but my understanding was it just put you on the same network? And we're already on the same network so...? Could it actually help or would it just be redundant?

I'm so confused and flustered.

UPDATE: Okay. So we tried Gameranger and wouldn't you know but it worked. Now I feel dumb. -_- I STILL don't understand WHY it didn't work with us being on the same network but problem solved.

Also is there a way to delete this? I hate to waste anyone's time.
Post edited July 20, 2013 by shara_shatley
No posts in this topic were marked as the solution yet. If you can help, add your reply