It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I played BG2EE for a few hours and loved it! It had german screen text and english audio. As I had problems with magic and other things, I bought BGEE, so I could learn the story from the first game, before continuing with the second.

But I really don't like the german audio. Turning the game to english gives me english audio, but also english text, that's too hard for me to understand.

So: Is there a way to have english audio, but german text?

Help is much appreciated. :-)
Here is the trick (no guarantee that it works for the entire game, just tried some steps ^^):

Locate you installation folder of Baldurs Gate, then
(1) go to "Baldurs Gate Enhanced Edition/game/lang/en_US/"
(2) rename "dialog.tlk", e.g. "dialog_en.tlk"
(3) copy "dialog.tlk" from "Baldurs Gate Enhanced Edition/game/lang/de_DE/" to "Baldurs Gate Enhanced Edition/game/lang/en_US/"

Ingame language settings should point to english. You now should have german text, but englisch speech.

(.... no idea about the dialogF.tlk in german folder though, thats why i said "no guarantee)
"dialogF.tlk" is used if the main character is female.

(The English version only needs a single "dialog.tlk", because it uses a simple token mechanism to vary pronouns etc. by gender -- but for some non-English languages that was not enough, so they use a separate TLK file for female main characters.)
Great! Now it's much less annoying. Especially Imoen sounds good now. :-)

Unfortunately it's mixed: The buttons have english names, but the explanations and dialogs are german. If anyone knows, how to get all the text in german, then help would be appreciated.

But all in all that solution is good enough. :-) Thank you very much, mmeyer!