}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
The rest of the series work fine. BG brings up the introductory menu, then when I try to start a game, I get a black screen and a bit later a CTD with a useful message that there are no valid video modes. I have latest drivers and all, but as it's a laptop, it's onboard video, so I can't do much there.

I've tried setting video to 1024x768, the only other setting it allows, but to no avail. I've tried the Widescreen mod, both at 1366x768 and 1024x768. Nada. Plugging in an external monitor that forces it into 1024x768 doesn't help. I've tried compatibility modes until I'm blue in the face.

But like I said, the rest work fine, and they work fine on my desktop machine. Other big difference is the laptop is 8.1, and I have 7 on my desktop. And if I set the desktop to 1366x768 it to that, it works, too.

Any ideas? Is it just that it's a crappy HP laptop?
No posts in this topic were marked as the solution yet. If you can help, add your reply
You could try running it i windowed mode by adding Full Screen=0 under [Program Options] in your Baldur.ini.
And while your there, if your BitsPerPixel=16 you could try changing it to BitsPerPixel=32.
Well, at least that gives me a different error message. And an intro screen I've never seen before. Multiplayer and Mission Pack both crash immediately, and Single Player lets me generate a character before crashing.

Thanks for trying.
Sounds like a permissions issue.
Could be your antivirus software.
Have you tried running the game as administrator?
If you right click on your Baldur's Gate folder Properties>Security does your username have write & modify permission?
The whole GOG Games folder has full permissions except special permissions. File attributes look good, too. I've tried running as administrator. Might be AV. I'll try disabling it this afternoon.

The message is

"An Assertion failed in D:\Dev\Baldur\chUI.cpp at line number 733"

which is kind of weird (Or maybe not; I don't really know very much about Windows 8. Maybe it throws random error messages when it doesn't feel like doing anything.) because while I do have a D: partition, it has no \dev directory. Used ATTRIB in case Win8 bars you from things marked SYSTEM (it does), but it's not there. All that's there are some read-only hidden system entries -- bootmgr, bootmgr.eff and RP.ini. That kind of stuff.

Didn't find anything in any of the BG .ini files that referenced drive D: at all. But I'm pretty sure I've seen that exact same message (probably different directory) in one of the other games I couldn't get working. Or maybe it was the same message, but one I got a few years back when I tried to install before and gave up.

[EDIT]
More accurately, there's a crapload of stuff there, but it's the recovery stuff. memtest.exe, a disk image, language selection, recycle bin, etc. But no Dev or Baldur or any of that. Makes me strongly suspect it's coming from someone else's setup.
[/EDIT]
Post edited January 24, 2018 by Thorfinn
avatar
Thorfinn: "An Assertion failed in D:\Dev\Baldur\chUI.cpp at line number 733"

which is kind of weird (Or maybe not; I don't really know very much about Windows 8. Maybe it throws random error messages when it doesn't feel like doing anything.) because while I do have a D: partition, it has no \dev directory.
It is referring to a line in the developer source code and has nothing to do with where you have the game installed, or even if you have a D: drive at all.

But 733 usually means you haven't installed something properly, either user error or interference by your antivirus software.
You first need to get the game working at default, make a save & then install the widescreen mod to a resolution you know your graphics card can display.
It's getting closer.

Did an uninstall, reboot, disable AVAST (anti-virus), install BG, set windowed, start the game and it lets me get to the point of selecting gender, then crashes, but now it says line 773.

Same message whether I set my desktop settings to 1366x768 or 1024x768, the only two options I'm allowed.
avatar
Thorfinn: ..
Have you tried enabling Direct Play? I believe it was somewhere like:

Control Panel --> Programs and Features --> Turn Windows Features on --> Legacy Components --> DirectPlay

I looked how to do it here.
https://www.youtube.com/watch?v=GNwiqCBwVek

Probably restart windows just to be sure.