It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I'm playing the original BG1 & 2 via BGT-WeiDU. I installed the fixpack unfinished business for both 1 and 2 and the new tweakpack (it's a combined one for BG,IWD,etc). I did NOT install the widescreen mod. I've always felt anything above 800x600 made everything too small for me. Anyway, I started the game and the screen is in a tiny window. Everything is so small I can hardly see anything. I went to BGconfig and changed it to 800x600 but that did nothing. I game ran fine in the past with these mods on this PC. I just reinstalled some games and this was one of them. It works fine other than this odd resolution thing.
No posts in this topic were marked as the solution yet. If you can help, add your reply
If you're intentionally trying to run in windowed mode, then yes -- it will appear very tiny. The game will not scale in a window and the native resolution is going to be very small on a modern high-res display.

If you meant that even in full-screen mode you're still only seeing a tiny play area surrounded by large black borders, then try installing the wide screen mod and set the resolution to 1280x720. If it works, that probably indicates either your monitor or graphics card is having trouble displaying the game's native resolution.
I tried clicking windowed mode and and it made no difference. The only difference was with windowed mode on, the tiny screen was surrounded by my desktop instead of a giant black border. I tried the widescreen mod and changed it to 800x600 but it made no difference. No idea why I'm having this issue. I never had an issue before. I was playing just a few month ago with no problem.
It's a Windows/Graphic card setting issue. You have to tell your graphics card to scale via the GPU, not the Windows desktop. With an nVidia card that's done in the 'Adjust Desktop Size and Position' area, and you would set it to 'Perform Scaling On >> GPU' Make sure that 'Aspect ratio' is checked and most importantly, make sure that 'Override the scaling mode for other programs' is checked. If you have another card, check for similar settings.
I was actually able to solve this myself. I checked all over my video settings and couldn't find anything to help. Then I remembered before having some issue with the 3D acceleration. I went into BG config and turned it off. Now it works fine. Have it set to 800x600 as I want. Thanks everyone for your suggestions!
If interested, to play with the 3D acceleration enabled and without the "small screen" or black borders problem, refer to my post at the bottom here: https://www.gog.com/forum/baldurs_gate_series/bg2_complete_the_screen_is_too_small/page1

Briefly: select the resolution options "Multiple displays" and "Duplicate on 2 and 3" using a cable or adapter connected to a 3rd monitor or a TV (off is OK) solves the black border/scaling problem for me with 3D Acceleration enabled, running at 1280x720 or at 800x600 (the best!).