It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

When I start Baldur's Gate II on Windows 7, the configuration dialog opens up every time. Normally, the config window should only appear on the first start, and once confirmed it shouldn't come up on subsequent startups. I had the CD version of the game installed previously, which didn't have the same issue. It's not a major problem, but it gets pretty annoying after the 5th game start.

I run the game on the administrator account, and User Account Control is disabled. Any idea what could be done to solve this issue?

Edit: I've also just checked baldur.ini, and the variable "First Run" is set to 0, as it should be. I really can't figure out what's wrong. Anyone else having the same issue?
Post edited November 17, 2010 by adamzs
This question / problem has been solved by searimage
Same thing here, just to confirm it's not you. I've given read/write access to the directory, so running as an admin shouldn't change anything...
Where have you got the game installed? If it's in Programs, try installing it elsewhere (such as C:\Baldurs Gate 2)
I've installed the game twice already to two different drives (none of them being the default location), so I believe the issue is independent of the install location. I've already contacted support about this and I'm currently waiting for the answer. I think the issue is universal on certain (or possibly all) systems, so hopefully they will address it soon.
Hopefully someone can find a solution for you, but I can tell you it's not universal on all systems. I have the game installed on my Win7 Pro 64 bit rig and it works fine. I've also installed a bunch of mods without issue. So it will definitely work. Looks like it's just a matter of figuring out what quirk of certain systems is causing the issue.

For reference, here's what I've done:

When installing my OS, I installed to a Solid State Drive. In order to cut down on writes/rewrites, I moved my User folder to a different hard drive altogether (this involved a registry edit, but it's a fairly simple process). I have my Games folder installed under Programs (not Programs x86), but it's also been moved to another drive and simlinked through Programs.

I installed BG2 like any other game into my Games folder, running as Admin. Once installed, I changed the properties of the desktop launcher to run in Windows XP SP3 compatibility mode and set it to run as Admin as well. (Even after doing that, I always right-click the launcher and choose to run as Admin when I play).

I then installed BGT with the Unfinished Business mod, BGTweaks for BG2, and the widescreen mod using GoJays' guide. Everything works great.
I had this same problem but after re-installing to it's own directory, it worked fine.
Thanks for the input, everyone. I haven't yet managed to solve the issue but I did find a workaround - if I create a shortcut to BGMain.exe instead of baldur.exe, then the game starts right away without the launcher or the configuration window. It makes starting up the game much faster for me.
You need to set the executables for the game as well as the configuration utility to run in compatibility mode for windows XP and also to run as administrator (right click the .exe file for both, and change compatibility mode to XP and click the box that says "run as administrator")

At least, this is what solved my issues with the problem you describe occuring on my Vista machine.
I've tried everything in this thread and I'm still unable to get this game running :/ I just keep getting the damn config tool over and over again.

Changed directory, reinstalled, changed permissions to the folder, run everything as Admin, in compatibility mode etc. nothing.
Are you starting the game with bgmain.exe?