It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Anybody know why?
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
TafferPatches: Anybody know why?
you have widescreen mod?
avatar
TafferPatches: Anybody know why?
What video card do you have?
Look for scaling options in your videocard control panel, or disable 3D acceleration in BGConfig.
avatar
TafferPatches: Anybody know why?
avatar
olnorton: What video card do you have?
Look for scaling options in your videocard control panel, or disable 3D acceleration in BGConfig.
This, and if its not enough you can create specials settings for BG2 original with your AMD drivers. I had the same problem, even with GPU scaling, you'll have to disable "surface format optimization".
avatar
olnorton: What video card do you have?
Look for scaling options in your videocard control panel, or disable 3D acceleration in BGConfig.
avatar
Zigmun: This, and if its not enough you can create specials settings for BG2 original with your AMD drivers. I had the same problem, even with GPU scaling, you'll have to disable "surface format optimization".
Where is the BGConfig file? I can't find it.

Videocard is Radeon 580 Strix
I wish someone could solve this. I played BG2 in Windows 7, and the screen size was fine. Once I went to Win 10, the screen became small. I sought support from GOG but was told the game wasn't designed to run on my computer. Now I've just upgraded to a newer, better computer, but I have the same problem.
I had the same issue...although I should note that I bought the original version of the game, before it was swallowed up by the Enhanced Edition. I more or less fixed the problem by following much of the advice contained in this link:

https://www.gog.com/news/enhance_the_gameplay_in_your_edition_of_baldurs_gate_from_gogcom
avatar
Hippias_Minor: I had the same issue...although I should note that I bought the original version of the game, before it was swallowed up by the Enhanced Edition. I more or less fixed the problem by following much of the advice contained in this link:

https://www.gog.com/news/enhance_the_gameplay_in_your_edition_of_baldurs_gate_from_gogcom
Thanks! I'll try that. I'm concerned, though, because the article says it enables one to play BG and the two sequels as one continuous game--and I'm not about to replay BG1 just to get to BG2. It took forever for me to finish BG1 (and I have no saved games); I'm not going through that again anytime soon--probably not in this lifetime.
avatar
p55carroll: I'm concerned, though, because the article says it enables one to play BG and the two sequels as one continuous game--and I'm not about to replay BG1 just to get to BG2. It took forever for me to finish BG1 (and I have no saved games); I'm not going through that again anytime soon--probably not in this lifetime.
That's only if you install BGT, which you don't have to.

As for the small screen, the answer is in this very thread if you read back. It's all a matter of scaling in your video control panel. It is a Windows 10 thing, not a game issue.
avatar
p55carroll: Thanks! I'll try that. I'm concerned, though, because the article says it enables one to play BG and the two sequels as one continuous game--and I'm not about to replay BG1 just to get to BG2. It took forever for me to finish BG1 (and I have no saved games); I'm not going through that again anytime soon--probably not in this lifetime.
Honestly, I don't recall everything that I did from that link--it was quite some time ago, and once I was sure I had everything up and running, I continued with other projects before returning to BG2. I can assure you, though, that I didn't do everything there--and that I, too, didn't restart BG1 and play the whole thing as just one game.

*If* I remember correctly, I just did the fixpack and then the widescreen mod. The result was satisfactory, although maybe you'd want to add the mod that increases text size or other mods to fine-tune your experience.

Whatever the case, the resources referenced in that link were enough to get things up and running for me.
avatar
Hickory: As for the small screen, the answer is in this very thread if you read back. It's all a matter of scaling in your video control panel. It is a Windows 10 thing, not a game issue.
Thanks. You were right. There are so many ways to get at the video settings, and so many things that can be done with them, that I'm always hesitant to go there. But I reread the above posts and noticed "disable 3D acceleration," and I didn't recall trying that before. All I had to do was uncheck that box and select the highest screen resolution available. Now the game is running just fine.
Based on the description of the problem in the OP, I can only guess, but here goes:

Briefly: for a laptop: select the resolution options "Multiple displays" and "Duplicate on 2 and 3" using a cable or an adapter connected to a 3rd monitor or a TV (off is OK) solves the black border/scaling problem for me with 3D Acceleration enabled, running at 1280x720.

See page 12 in my walkthrough for BG2:
http://www.scribd.com/doc/71232387/Baldur-s-Gate-2-Walkthrough-for-SoA-ToB-Cleric-Ranger
https://www.slideshare.net/bg2mez/baldurs-gate-2-walkthrough-for-soa-tob-clericranger-72287979

Or see the post: https://www.gog.com/forum/baldurs_gate_series/black_border_small_screen_scaling_problem_with_3d_acceleration_with_baldurs_gate_2_a_solution

Or, simply disable 3D Acceleration. This is for BG2 and BG Trilogy.

Note that BG1 does not have this problem.