It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello. I just bought Baldur's Gate (1) and I get this error when launching the game:

"An Assertion failed in D:\Dev\chitin\ChVideo.cpp at line number 4256 Programmer says: No valid video modes supported."

If I use the .ini file to launch in windowed mode, game works until I get similar "assertion failed" errors and crashes again. I am using Windows 10, i7-4770k, GTX760, 1920x1080 desktop resolution, reinstalled my drivers, reinstalled the game 2 times, other modern games work fine, I sent email to GOG support with no reply yet.
Anyone had similar situation and could help me out? Thanks in advance!
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
Coledash: Hello. I just bought Baldur's Gate (1) and I get this error when launching the game:

"An Assertion failed in D:\Dev\chitin\ChVideo.cpp at line number 4256 Programmer says: No valid video modes supported."

If I use the .ini file to launch in windowed mode, game works until I get similar "assertion failed" errors and crashes again. I am using Windows 10, i7-4770k, GTX760, 1920x1080 desktop resolution, reinstalled my drivers, reinstalled the game 2 times, other modern games work fine, I sent email to GOG support with no reply yet.
Anyone had similar situation and could help me out? Thanks in advance!
What mods do you have installed? Post the contents of your weidu.log here.
Thanks for the reply, but I dont have any mods installed, I did try widescreen mod to try out different resolutions, but it didnt work.
avatar
Coledash: Thanks for the reply, but I dont have any mods installed, I did try widescreen mod to try out different resolutions, but it didnt work.
Then it's highly likely that the widescreen mod hasn't been uninstalled correctly, and/or you are using saved games created with the widescreen mod installed. Since you have just bought the game, the best thing you can do is completely uninstall it and then re-install without the widescreen mod, and create new save games -- don't use your old ones.
Hey, I am having the same issue as the original poster. I have no mods or anything. Just bought the game last night and havent gotten it to run yet.

Getting the same message when trying to launch: An Assertion failed in D:\Dev\chitin\ChVideo.cpp at line number 4256 Programmer says: No valid video modes supported."

Any ideas?
avatar
rdm1121: Hey, I am having the same issue as the original poster. I have no mods or anything. Just bought the game last night and havent gotten it to run yet.

Getting the same message when trying to launch: An Assertion failed in D:\Dev\chitin\ChVideo.cpp at line number 4256 Programmer says: No valid video modes supported."

Any ideas?
What is your desktop resolution?
1920 x 1080
avatar
rdm1121: 1920 x 1080
Try starting it in windowed mode. Open baldur.ini and look for the line
Full Screen=1

Change it to
Full Screen=0

If that works, have the window selected and press ALT+ENTER to return to full screen.
Post edited November 26, 2015 by Hickory
forgive my lack of knowledge but where might i find baldur.ini? I have searched for it in several places and come up with nothing
avatar
rdm1121: forgive my lack of knowledge but where might i find baldur.ini? I have searched for it in several places and come up with nothing
It's in your Baldur's Gate installation folder.
Theres no option for that in the ini

im having the same issue my error says Assertion failed in D:\dev\chitin\chdimm.cpp at line number 581
programmer says: Unable to open BIF:data\SFXSound.bif
Post edited February 25, 2018 by SPIN_