It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I've installed Baldur's Gate 2, with mods, on my Linux PC, and I'm currently smoothing out the issues that go along with that. But that's not what this post is about.

When I run BG2 from the script, the first thing it does is permanently disconnect my second monitor. It no longer shows up in display settings, and I can't find any software based method to get my PC to detect it again. The only reliable way is to disconnect the display, reboot, then plug it back in after I log in.

I can't be doing this every single time I try to run the game to test the multitude of other problems I'm currently dealing with. I haven't been able to figure out exactly which script is turning off my monitor.

If anyone knows how to fix this infuriating behaviour from the scripts, or how to reconnect my monitors, it would be much appreciated, as I can then get back to solving the real problems.


UPDATE: I can reconnect my second monitor with xrandr --auto. I would still like to have my second monitor not be switched off though.

UPDATE 2: Running the launcher with the windowed option runs the fullscreen game, but doesn't disable the second monitor. This is a solution enough for me, for now, but I'll leave this around in case anyone runs into the same problem I did.
Post edited January 19, 2020 by CR_Soren
No posts in this topic were marked as the solution yet. If you can help, add your reply