It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
Hickory: ...
Yeah.

I think Core Temp might display a physical core with 1 logical core at 100% utilisation and 1 logical core at 0% utilisation as just the physical core at 50% utilisation.

What I'm trying to say is, on your system Baldur's Gate 2 might be using ~98% of what it sees as the CPU.

---

The issue isn't that the game seems to be running a core at 100%, but rather that timppu's laptop seems to lack adequate cooling for its CPU (or has something preventing it from functioning properly) when it's running a core at full load and at full speed - which shouldn't be an issue for most PCs.
Post edited September 16, 2013 by DreadMoth
avatar
Hickory: I don't know why I'm even bothering to reply, but...

You must have an issue with Core Temp or a something connected with it -- those tools are not perfect or foolproof -- because, as this image of my Core Temp shows, during the fighting of Firkraag (a dragon being the most graphic intensive part of a BG2 game), my single core CPU usage is at 49%. Do not blame the game. I repeat, it is NOT the game.
Yes it is.

First things first, you probably noticed that your CPU usage was _locked_ to ~50% all the time, right? Add to that what DreadMoth says later, ie. it doesn't go beyond 50% just because the game thinks it has already hit the 100% cap.

I tested BG and BG2 (GOG versions) on a few other PCs I have, and I got similar results on all:

ASUS G75VW (Windows 7/64bit): One of the four cores was locked to 50% all the time (ie. apparently what the game thinks is 100%). So the same case as with you then.

My old AMD XP 2000+ (1.66GHz single core) with ATI Radeon X800 Pro (Windows XP 32bit): core was locked to 100%.

Lenovo ThinkPad T400 (Windows 7/64bit): one of the two cores locked to 100%.

I decided not to try it on my ancient IBM ThinkPad T41 (single core, running Windows XP) as I didn't think it would bring any new data. Probably it would be locked to 100%.

All this points to the same: no matter how fast your CPU is, BG and BG2 try to use up all the CPU cycles they can find. Maybe they have a good reason to do that, I don't know, but it just seems somewhat excessive, considering that locking e.g. the T400 CPU speed to a much lower value still runs the game exactly the same, but just using much less power (and producing much less heat).

In all the aforementioned systems, Baldur's Gate 2 ran smooth and great with max settings. And why wouldn't it, as they are all well beyond the recommended max PC configurations of BG2 (which is about some 600MHz CPU with some low end 3D graphics card).
Post edited September 16, 2013 by timppu
avatar
timppu: However, in this case the CPU core stays at 100% as soon as you launch the game, no matter whether you are watching the BG2 intro videos, or the menu screen, or actually are playing the game.
Yes, a number of old games exhibit such behavior. Another example are the I Spy games. Those are point & click, no 3D, etc.

avatar
timppu: (BG2 is doing its own CPU burn testing while I am playing the game).
Not quite. 100% CPU isn't all the same. Whatever BG2 is doing is a lot less stressful than e.g. calculating π.

avatar
DreadMoth: The issue isn't that the game seems to be running a core at 100%, but rather that timppu's laptop seems to lack adequate cooling for its CPU (or has something preventing it from functioning properly) when it's running a core at full load and at full speed - which shouldn't be an issue for most PCs.
Blowing out any dust is a good idea. A lot of laptops have broken designs and are not able to run at capacity for extended lengths of time.
avatar
DreadMoth: 100% usage on your CPU shouldn't be causing overheating (same applies to GPUs) - is there any dust built up in/around your laptop's fans/vents? Maybe the cooling isn't adequate for the system, something that seems to be common with laptops.
I think it is beside the point whether there is enough cooling or not, I was mostly interested in that is this really how these games are supposed to run (apparently yes?), and maybe also why these games want to use up all CPU cycles they can find. Lazy programming?

I had those overheating issues mainly just when my old T400 laptop was sitting on a dock station, maybe that somehow blocks the ventilation a bit. When I use it separately, it runs cooler, also with BG2. When I tried BG2 e.g. on my newer ASUS G75VW laptop (where one core was locked to 50%), it ran quite cool.

It just feels somewhat... stupid, that the game tries to run at 100% power on anything it can find. Maybe I'd like to play the game on battery power, in which case it excessively uses too much power, when it could clearly do with much less? Or, I wouldn't like listening to a fan speeding up to full speed just for one 13 years old game? Just as two examples. Fortunately with laptops you can force the system to use less CPU power, when I set the max CPU speed to low level on my T400, it was still plenty for BG2, ie. it ran the same at max settings as with unlimited CPU speed.

avatar
DreadMoth: I've seen quite a lot of older games/programs running a core at 100%, I think they were probably intended to do so - as you said, it's just grabbing any free cycles it can find.

EDIT: Running Arcanum in the background at the moment (don't have any IE games installed at the moment), it seems to be using most of a core and my CPU has reached a maximum temperature of 59°C.
I tried running a couple of other games too on that same T400 ("The Wheel of Time" and "Diablo 2: LoD", from about the same era or earlier than BG2 + ToD), and they ran much more sanely: first of all they used both cores, and the CPU usage (on either core) was not locked to any specific value, but it varied all the time as I was playing. E.g. in menus CPU usage was much lower than during the busiest gameplay; makes sense, huh?

In comparison, BG2 seems a bit silly how it locks itself to 100% usage as soon as I run it, during intro videos, static menus and gameplay.

But enough of that, I just have to deal with it I guess. I guess I wouldn't want to play Baldur's Gate 2 in Thailand in a +35 Celsius room without air con. :)
Post edited September 16, 2013 by timppu
low rated
avatar
timppu: Yes it is.
Wrong.

First things first, you probably noticed that your CPU usage was _locked_ to ~50% all the time, right?
Wrong.

ASUS G75VW (Windows 7/64bit): One of the four cores was locked to 50% all the time (ie. apparently what the game thinks is 100%). So the same case as with you then.
Wrong.

avatar
timppu: I think it is beside the point
Right.
avatar
timppu: I think it is beside the point whether there is enough cooling or not, I was mostly interested in that is this really how these games are supposed to run (apparently yes?), and maybe also why these games want to use up all CPU cycles they can find. Lazy programming?
Or perhaps they did well to write a game that would wring every bit of performance out of the system it was running on, and didn't account for the following 13 years of PC hardware development or even the fact that their game would still be played after all that time... ;)
avatar
Hickory: Wrong.

Wrong.

Wrong.
LOL! At this point the only one who seems to agree with you anymore is you.
avatar
Crispy78: Or perhaps they did well to write a game that would wring every bit of performance out of the system it was running on, and didn't account for the following 13 years of PC hardware development or even the fact that their game would still be played after all that time... ;)
Considering that the game runs just as well, with all the bells and whistles, if I drop my PCs max CPU speed to a much lower value (so that BG2 can muster much less CPU cycles before hitting the 100% cap), it appears to me it is just wasting rest of the CPU power, for whatever reason. Maybe it is some kind of simple timing hack or something, wasting any extra CPU cycles that it doesn't need? Someone who is an actual games programmer knows better.

Diablo 2 and The Wheel of Time, two other games from the same era, seem to behave much better, ie. using more CPU power only when they really need it. With them the CPU utilization is not locked to e.g. 100% all the time, but it fluctuates all the time depending what is happening in the game, going much lower also on game menus etc.

While it is true that PCs should handle constant 100% CPU and GPU usage without any problems, it still just sounds wasteful and excessive to me if it is used with no good reason. For instance, I think people would mind if Windows always did the same if you are merely staring at an empty desktop, ie. your CPU and GPU would always be working overtime even though there isn't really anything for them to do.

Or to take a car analogy, if I noticed that my gear was stuck to second gear, which would cause my engine to go 6000 rpm on a highway at 80 km/h or more, I probably wouldn't be content with just "Well, I wouldn't worry about it if I were you. Your car engine is specced to handle constant 6000 rpm without breaking up, so why would you care if it is running at that all the time?". :)

Anyway, not much to do about it I guess, just have to deal with it. Maybe I'll set my older laptop's max CPU speed to a lower value whenever I run BG2, just so that I don't have to listen to the fan spinning at full speed without a good reason. :)

The main point of the original discussion was just to get a confirmation whether these games are really supposed to work this way (I think the answer is yes, so nothing wrong with the PCs where the CPU usage constantly hits 100% with these games), and why are they doing it (not known).
Post edited September 17, 2013 by timppu
I know this is a very old thread but I found through google and may eventually help pthers who do the same.
I purchased populous 3 long time ago but was still playing my old copy on the laptop. I decided to install it on the windows tablet and the frame rate was very low. Tried some stuff untill I notice 1 of the 4 cores was always 100%, no matter what.

Simply right click on the desktop shortcut and remove the compatibility mode to WIN95. All cores are working and frame rate is good now.