It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

First time I tried the game, it worked fine.

After a PC restart (to finish installing Adobe Acrobat Reader, it now crashes on startup, right after the menu asking for resolution etc. Have tried different resolutions, but get a crash regardless. Also tried reinstalling without success.

Running Windows 7 64-bit, Core i7 3770, AMD RX480 Graphics.

Anybody seen similar issues and hopefully have a fix?

No posts in this topic were marked as the solution yet. If you can help, add your reply
I had similar issues with unity games, lately, and I fixed them with this :

Just changing a parameter in my graphic card settings.
Post edited October 09, 2018 by Telika
I just installed the latest update to the GOG Galaxy launcher. Now the game works fine, perhaps it had something to do with the launcher?

Anyway, seems to work fine now!