It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So I recently installed this on my windows 8 machine (laptop). Previously, i used to start the game with the default executable, which is assassinscreed_game.exe. I guess that would launch the game on dx10 mode by default on systems higher than windows Vista. I used to get a horrible lag in this mode. Some areas lagged so heavily, the frame rates would drop drastically making the game almost unplayable.
I did some research on google and some forums where people said that the problem is solved when you launch the dx9 version of the game. I tried it and, guess worked. No more lags and fps drops. The game ran as smooth as butter even in graphic intensive areas.
Does anyone know why this happens. Windows 8 is a dx11 compatible system and even my version of diectx is 11. I think it should run the dx10 mode without any problems. But unfortunately that's not the case