It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I'm running Windows 7, and after I select New on my profile, I end up at white smoky screen with symbols popping up all over the place. It never transitions to anything else. Eventually I Alt-F4ed out and come to post here. Based on the time of the last interaction on this forum, I'm guessing that I might not get an answer that soon, but I'd like to play this game eventually.

Thanks to anyone who can help me with this.
No posts in this topic were marked as the solution yet. If you can help, add your reply
mdtexeira: ...Thanks to anyone who can help me with this.
In the game's installation folder are executables to start the game with DirectX9 or DirectX10 support. Try starting the game with them.

Some users also get it running by disconnecting the Internet connection (unplug the cable or disable your wireless device).
Post edited November 05, 2014 by DeMignon
None of that worked for me. I'm running it as an administrator as well, DPI scaling or whatever is turned on. It's quite puzzling. As I said, the screen it stays at is, I think, a loading screen.
Hmm, okay. Than let's sort out some standard things, which could cause problems.

- Update your graphics drivers
- Install DirectX 9 End-User Runtimes
- Run the DirectX Web Installer afterwards
- Re-install the game
- Reboot your PC
- Disable any anti-virus software while playing
Hmmm...the driver thing will have to wait. The most recent drivers for the GTX 770 are just out and I never update to brand new drivers right away...I prefer to see if they're breaking anything first. The thing is, the graphics all seem fine. I'll give the DX9 thing a shot tomorrow (it is just about time for sleep here), and try disabling my AV right now and see if that helps.
I had the exact same issue and I solved it by re-installing it in the C:\Program Files (x86) folder. I had installed it on a different drive and it was not working.