It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I had Ashes working fine throughout the week and then spontaneously it started throwing up the error on launch that the Graphics card was unsupported.

There has been no system update, no graphics update and Ashes itself has not updated.

I have a Radeon RX480 and it's running the most recent drivers. I've tried reinstalling, I've tried running in DX11/12 I've checked to ensure that Direct X and everything else is up to date. I've tried installing on different hard drives and also tweaking the Radeon settings. Nothing has worked.

Does anyone have any idea how to fix this? I've seen a few other people with this problem but it doesn't seem like anyone has an answer.
i always get this error as well with my GTX 750 Ti (even after driver updates). but the game still works anyway, after acknowledging the error window. I have multiple versions of the original game and Escalation, and all versions i have cause the error on startup for me.

Does the game still work for you anyway?
Did you raise a ticket with support? i never bothered as the game still worked for me

btw i'm running it on Win10.
Post edited June 29, 2017 by tedeee