It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

First, the context: this is the second time I play the game, I still have original box and first played it about 10 years ago on Windows 2000; current replaying on a Windows 7 64 bits laptop with patch 1.21 and Arx Libertatis (it would not start on my system without it).

I want to play this time around in 'nice guy' mode, trying to solve everything the peaceful way if that is possible.

So, I got got the code, opened the secret passage, and sent the king on an extended toilet vacation.

I tried to talk to both the guard near the treasure room and the guard blocking access to the reservation room (blocking entrance to room 31 on this map: )
I showed both all 3 quest text messages ( the one about the king's allergy to wine, the one with the code, and the one about the death threat), then talked to them until theit reaction became invariant, then went back to the king.
The king does not react to any of those 3 either, nor does he instruct the guard to let me access the room, which he is supposed to do; I basically need to know precisely which paper need to be shown to which guard and which paper to the king, for him to unlock the situation.

I have penty of saves to older stages in the game, but I would like to be 100% sure that I hit a bug and did what I should have, before backtracking to an earlier save and restart this area.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Never mind, there is a bug: keeping up the search, I just found a walkthrough for this quest on YouTube, and there was no goblin where in my case there is one permanently blocking the way to room 31...

I need to talk to the goblin in room 31 at the door to room 34, for the king to tell them to let me pass.
So basically I need to backtrack until I find a save where this goblin is not stuck in this doorway (he was there since I passed the porticulis)... or find a way to push him out of the way.
Post edited October 16, 2012 by Fafhred
Bug unterstood and workaround found:

Now that I knew it was a bug, I did some experimentation:
- The earliest save I found where that goblin was not stuck in that door was about 4 hours of game time ago (about 12 hours real time).
- The next save after that was interesting, as it gave 50/50 odds of the goblin being stuck there.

This gave me the hint I needed, so I then experimented (with a recent save having that bug) trying to switch map, save, reload, then going back to this map (doing this on the same map did not change anything)... and it worked: the first time it was still stuck, but the second time it had moved out of the doorway when I arrived back there.
Thanks for writing down your findings, Fafhred! I'm having the exact same problem and spent nearly a whole night trying to solve it. Gonna try your solution in my next attempt.

Do you still have the link to the specific walkthrough you mentioned?
Just found it again for you.

It is in 2 parts:
Arx Fatalis - Troll quest 1/2 at
Arx Fatalis - Troll quest 2/2 at
Thanks for sharing!