It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I recently installed the game; however, I'm not getting a main menu and thus can't do anything. According to the official FAQ, disabling the anti-virus should fix it. It didn't. I then tried reinstalling with the anti-virus disabled. Still no menu.
I'm using Avira Antivirus. I disabled the AVGuard component, which is the active scanning thing; however, avguard.exe is still in memory and the process cannot be killed. Is that's what is causing the problem?
I tried running the demo and it worked fine.
Also, antialiasing is disabled, and my GPU's not forcing anti-aliasing.
System:
Windows XP Pro
Centrino Duo 2ghz
1 gig ram
Intel 945GMA
Post edited December 31, 2009 by amccour
No posts in this topic were marked as the solution yet. If you can help, add your reply
Also if you using nVidia graphic card like GeForce from driver series Forceware 93.17 - you could open up nVidia Panel (right-click on desktop) -> 3D Settings -> Use advanced 3D settings (take me to) -> TURN ON Application Extensions (or TURN OFF if they are TURNED ON). Its mainly use with older apllications (Arx Fatalis is such one), turning it on could help with crashing and graphic issues.

Dunno will it work with newer GeForce cards, haven't met them, also unknown to me how their control panels looks and works.

But it is worth a try.
To everyone who is experiencing the no menu bug:

In your Arx Fatalis directory (eg C:\Program Files\GOG.com\Arx Fatalis) there is a sub-directory called 'misc' that contains multiple font files. For whatever reason, some installations will occasionally install the game with a bugged default font file (Arx.ttf); if you double-click this font file and don't see any letters, it means your file is bugged. This happened to me.

HOWEVER. For whatever reason, one of the other font files (in my case it was arx_russian.ttf) actually ended up being the correct English font file. After re-naming arx.ttf to 'oldfont.ttf' for backup purposes and then renaming arx_russian.ttf to Arx.ttf, the game worked perfectly.

It is also worth noting that the game seems to have a problem with forced anti-aliasing; when I used my nVidia control panel to add 4x AA, the fonts stopped displaying. So if you have any such external graphical settings enabled, you'll need to turn them off. It makes the game look a bit rougher around the edges (har, har) but believe me, it's worth it.

Hope this helps!