It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Nothing when I hit the shortcut, but here is what happens in the terminal:

[I] Startup:159 Starting Arx Libertatis 1.2-dev-2017-12-02 + efddfd8
[I] ArxGame:336 Using config file "/home/steven/.config/arx/cfg.ini"
[I] ArxGame:283 Changing filenames to lowercase...
[I] SDL2Window:169 Using SDL 2.0.6
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 4 (X_DestroyWindow)
Resource id in failed request: 0x0
Serial number of failed request: 195
Current serial number in output stream: 196

All the pak files are in the .local/share/arx directory. Any ideas?

I assume you are using the Ubuntu package of the development snapshot? If so can you try the portable binaries to see if they work better for you.

Please also check if disabling multisampling allows the game to start. To do that edit ~/.config/arx/cfg.ini and change the line antialiasing=true to antialiasing=false. If the file does not exist create a new one with the following contents:

Post edited December 06, 2017 by dscharrer
Portable Binary was incredibly slow with the fps. But changing antialiasing worked for the other installation! So that works so far thanks!