It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I managed to install the game just fine, but when I try to start it, nothing happens, apart from that it shows up in the task manager, with a memory usage of around 10MB. Killing the process just removes it, with no error message. Starting the game again, while there already is one in the task manager, just starts up another with the exact same symptoms.
I've also tried a clean boot, but no difference.
If it helps, my specs are:
Vista Ultimate (32bit)
HD4870 512MB
Athlon 64 X2 6000
Apparently it had nothing to do with the graphic drivers. I'm now using 8.11 with the exact same results.
Post edited December 05, 2008 by sheepdragon
This question / problem has been solved by Karlallenimage
madhog6: Wouldnt start up when i first installed it. then I downloaded something called portable arx fatalis It ran once after that. Next time I started up computer, it went right back to the same problem. No idea what it did, all i did was extract it somewhere in c:/. Maybe one of you more tech savvy people can link together wtf happened. Cause I have no idea.
I haven't tried the portable version but that would only work when running it from ArxFatalisPortable.exe rather than the normal executable or its shortcuts.

Failing that you could try Arx Libertatis.
this game installs fine but when i try to launch blank screen cant even open task manager have to restart using button on pc win 7 64bit amd 7870 thought these old game supposed to work have 5 games with simular launch problems