It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
avatar
AnyaB: Since I found this forum, searching for my own Windows 8.1 Arcanum lag issues, I thought I might mention how I fixed mine (so far, as it appears).

I have GOG Arcanum installed as well as the Unofficial Patch, High Res, HQ Town Maps.

1. I overwrote my existing Arcanum ddraw.dll with the DDraw Fix.

The ddraw fix can be downloaded alone by searching for Aqrit's DDrawFix.
I didn't use the provided exe, simply extract, cut and paste into Arcanum folder, the following;
ddraw.dll
wined3d.dll
libwine.dll

2. Then add -doublebuffer -no3d to the Arcanum shortcut after Target: "Arcanum.exe"
(Mine looks like this "C:\GOG Games\Arcanum\Arcanum.exe" -doublebuffer -no3d)

I don't know if all the .dlls are needed, but since everything seems to be working fine now. I haven't bothered to further experiment.

Also NOTE: This doesn't require Arcanum to be run in a window.
The -doublebuffer -no3d alone didn't work for me, neither did renaming or removing the existing Arcanum ddraw.dll. And, the ddraw fix alone didn't work without said shortcut addons.

I came upon this all by accident/experiment after looking at Baldur's Gate which runs fine on my Windows 8.1 and found the ddraw fix folder...

Hope this helps someone else.
Thanks Arcanum runs perfectly now at 2560x1440. The videos are smooth and load times are instant instead of 30 seconds.
avatar
AnyaB: Since I found this forum, searching for my own Windows 8.1 Arcanum lag issues, I thought I might mention how I fixed mine (so far, as it appears).

I have GOG Arcanum installed as well as the Unofficial Patch, High Res, HQ Town Maps.

1. I overwrote my existing Arcanum ddraw.dll with the DDraw Fix.

The ddraw fix can be downloaded alone by searching for Aqrit's DDrawFix.
I didn't use the provided exe, simply extract, cut and paste into Arcanum folder, the following;
ddraw.dll
wined3d.dll
libwine.dll

2. Then add -doublebuffer -no3d to the Arcanum shortcut after Target: "Arcanum.exe"
(Mine looks like this "C:\GOG Games\Arcanum\Arcanum.exe" -doublebuffer -no3d)

I don't know if all the .dlls are needed, but since everything seems to be working fine now. I haven't bothered to further experiment.

Also NOTE: This doesn't require Arcanum to be run in a window.
The -doublebuffer -no3d alone didn't work for me, neither did renaming or removing the existing Arcanum ddraw.dll. And, the ddraw fix alone didn't work without said shortcut addons.

I came upon this all by accident/experiment after looking at Baldur's Gate which runs fine on my Windows 8.1 and found the ddraw fix folder...

Hope this helps someone else.
I can't for the life of me understand why this particular combo of things works, or how anyone could think of all of them at once, but it does. Maybe it's a conflict when all 3 mods aren't installed, maybe it's the off the wall fix of putting in the Infinity Engine .dll fixes, but it works. The dialog options box doesn't lag, the load times are instant, but the original poster is right. None of this works on it's own, together, on a fresh install, they do. I'd also add I set the Hi-Res mod to the lowest possible numbers and also have the program running in Windows 7 compatability mode.
Post edited November 15, 2015 by jjstraka34
avatar
AnyaB: Since I found this forum, searching for my own Windows 8.1 Arcanum lag issues, I thought I might mention how I fixed mine (so far, as it appears).

I have GOG Arcanum installed as well as the Unofficial Patch, High Res, HQ Town Maps.

1. I overwrote my existing Arcanum ddraw.dll with the DDraw Fix.

The ddraw fix can be downloaded alone by searching for Aqrit's DDrawFix.
I didn't use the provided exe, simply extract, cut and paste into Arcanum folder, the following;
ddraw.dll
wined3d.dll
libwine.dll

2. Then add -doublebuffer -no3d to the Arcanum shortcut after Target: "Arcanum.exe"
(Mine looks like this "C:\GOG Games\Arcanum\Arcanum.exe" -doublebuffer -no3d)

I don't know if all the .dlls are needed, but since everything seems to be working fine now. I haven't bothered to further experiment.

Also NOTE: This doesn't require Arcanum to be run in a window.
The -doublebuffer -no3d alone didn't work for me, neither did renaming or removing the existing Arcanum ddraw.dll. And, the ddraw fix alone didn't work without said shortcut addons.

I came upon this all by accident/experiment after looking at Baldur's Gate which runs fine on my Windows 8.1 and found the ddraw fix folder...

Hope this helps someone else.
Just posting to say that this worked beautifully and was quick and easy to do. Thanks!

Maybe GOG can hopefully update it to include this fix as an option for those who need it, at the time of installation.
avatar
AnyaB: Since I found this forum, searching for my own Windows 8.1 Arcanum lag issues, I thought I might mention how I fixed mine (so far, as it appears).

I have GOG Arcanum installed as well as the Unofficial Patch, High Res, HQ Town Maps.

1. I overwrote my existing Arcanum ddraw.dll with the DDraw Fix.

The ddraw fix can be downloaded alone by searching for Aqrit's DDrawFix.
I didn't use the provided exe, simply extract, cut and paste into Arcanum folder, the following;
ddraw.dll
wined3d.dll
libwine.dll

2. Then add -doublebuffer -no3d to the Arcanum shortcut after Target: "Arcanum.exe"
(Mine looks like this "C:\GOG Games\Arcanum\Arcanum.exe" -doublebuffer -no3d)

I don't know if all the .dlls are needed, but since everything seems to be working fine now. I haven't bothered to further experiment.

Also NOTE: This doesn't require Arcanum to be run in a window.
The -doublebuffer -no3d alone didn't work for me, neither did renaming or removing the existing Arcanum ddraw.dll. And, the ddraw fix alone didn't work without said shortcut addons.

I came upon this all by accident/experiment after looking at Baldur's Gate which runs fine on my Windows 8.1 and found the ddraw fix folder...

Hope this helps someone else.
Finally thank you so much!
avatar
AnyaB: Since I found this forum, searching for my own Windows 8.1 Arcanum lag issues, I thought I might mention how I fixed mine (so far, as it appears).

I have GOG Arcanum installed as well as the Unofficial Patch, High Res, HQ Town Maps.

1. I overwrote my existing Arcanum ddraw.dll with the DDraw Fix.

The ddraw fix can be downloaded alone by searching for Aqrit's DDrawFix.
I didn't use the provided exe, simply extract, cut and paste into Arcanum folder, the following;
ddraw.dll
wined3d.dll
libwine.dll

2. Then add -doublebuffer -no3d to the Arcanum shortcut after Target: "Arcanum.exe"
(Mine looks like this "C:\GOG Games\Arcanum\Arcanum.exe" -doublebuffer -no3d)

I don't know if all the .dlls are needed, but since everything seems to be working fine now. I haven't bothered to further experiment.

Also NOTE: This doesn't require Arcanum to be run in a window.
The -doublebuffer -no3d alone didn't work for me, neither did renaming or removing the existing Arcanum ddraw.dll. And, the ddraw fix alone didn't work without said shortcut addons.

I came upon this all by accident/experiment after looking at Baldur's Gate which runs fine on my Windows 8.1 and found the ddraw fix folder...

Hope this helps someone else.
Another thank you, after a half dozen different things I tried, it runs very smooth. And this is Windows 10, nothing else I tried helped at all.
avatar
AnyaB: Since I found this forum, searching for my own Windows 8.1 Arcanum lag issues, I thought I might mention how I fixed mine (so far, as it appears).

I have GOG Arcanum installed as well as the Unofficial Patch, High Res, HQ Town Maps.

1. I overwrote my existing Arcanum ddraw.dll with the DDraw Fix.

The ddraw fix can be downloaded alone by searching for Aqrit's DDrawFix.
I didn't use the provided exe, simply extract, cut and paste into Arcanum folder, the following;
ddraw.dll
wined3d.dll
libwine.dll

2. Then add -doublebuffer -no3d to the Arcanum shortcut after Target: "Arcanum.exe"
(Mine looks like this "C:\GOG Games\Arcanum\Arcanum.exe" -doublebuffer -no3d)

I don't know if all the .dlls are needed, but since everything seems to be working fine now. I haven't bothered to further experiment.

Also NOTE: This doesn't require Arcanum to be run in a window.
The -doublebuffer -no3d alone didn't work for me, neither did renaming or removing the existing Arcanum ddraw.dll. And, the ddraw fix alone didn't work without said shortcut addons.

I came upon this all by accident/experiment after looking at Baldur's Gate which runs fine on my Windows 8.1 and found the ddraw fix folder...

Hope this helps someone else.
Thank you so much, for your comment about stopping lag. There needs to be more, helpful people like you around! I can now play again, using windows 10.