It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Is this a oversight from the devs or a bug or something?

Can anyone please confirm?

Il message the devs in the meantime.
avatar
GameMaster_83: Is this a oversight from the devs or a bug or something?

Can anyone please confirm?

Il message the devs in the meantime.
I have the same query. Any update ?
avatar
GameMaster_83: Is this a oversight from the devs or a bug or something?

Can anyone please confirm?

Il message the devs in the meantime.
avatar
darkmar3: I have the same query. Any update ?
It appears to be just an oversight, the current version contains all the fixes and features from the latest patch notes.
On the manual download page, there is now a 1.01 to 1.03 patch. But the game on that download page also says version 1.03! Don't trust it. It IS 1.01, and you WILL need to download the patch!