It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Happens allways upon entering location.

[code]
Build Date: - DRM FREE - 1.3v - 06.08.2018 - 16:17:10 Loading village-act1 ----------------Starting village-act1 : 00:00 - Realtime: 00:00 ----- Gamepad: False - Difficulty: Easy Level Trigger: wall1 Level Trigger: wall6 Level Trigger: firstdoor Level Trigger: wall2 Level Trigger: wall3 Level Trigger: FirstRaiderKilled Level Trigger: wall4 Level Trigger: RUN_TO_ENEMIES Level Trigger: AllowDeath Level Trigger: obj-village Level Trigger: CombatMusicOn World Trigger: objectives-shown Level Trigger: wall5 Level Trigger: MapTutorial Level Trigger: FIGHT_TIME Level Trigger: wall6 Loading village-act1-blacksmith ----------------Starting village-act1-blacksmith : 00:00 - Realtime: 00:01 ----- Gamepad: False - Difficulty: Easy 09:50:12.252-CRASH: Update 09:50:12.262-System.NotImplementedException: Unhandled CrossfadeType! at Microsoft.Xna.Framework.Audio.Cue.INTERNAL_update () [0x003cf] in <f3ab48f067a3473da7066668d8e4892d>:0 at Microsoft.Xna.Framework.Audio.AudioCategory.INTERNAL_update () [0x00024] in <f3ab48f067a3473da7066668d8e4892d>:0 at Microsoft.Xna.Framework.Audio.AudioEngine.Update () [0x0016d] in <f3ab48f067a3473da7066668d8e4892d>:0 at Apotheon.Soundtrack.Update (Microsoft.Xna.Framework.GameTime gameTime) [0x00000] in <230caef5ccf747dcbbb2f3461a9ca672>:0 at Apotheon.ScreenManager.UpdateAudio (Microsoft.Xna.Framework.GameTime gameTime) [0x00027] in <230caef5ccf747dcbbb2f3461a9ca672>:0 at Apotheon.ScreenManager.Update (Microsoft.Xna.Framework.GameTime gameTime) [0x000f5] in <230caef5ccf747dcbbb2f3461a9ca672>:0 at Microsoft.Xna.Framework.Game.Update (Microsoft.Xna.Framework.GameTime gameTime) [0x00078] in <f3ab48f067a3473da7066668d8e4892d>:0 at Apotheon.Start.Update (Microsoft.Xna.Framework.GameTime gameTime) [0x00000] in <230caef5ccf747dcbbb2f3461a9ca672>:0 09:50:12.265-Total Memory: 156959KB 09:50:12.265-- DRM FREE - 1.3v - 06.08.2018 - 16:17:10
[/ code]
Post edited July 04, 2019 by marc12polo3
Same here, seems like the Linux version is broken... :(
avatar
marc12polo3: Happens allways upon entering location.
Maybe it will be fixed:
I posted same on steam forum and got Dev reply, that they are making new version.
avatar
marc12polo3: Maybe it will be fixed:
I posted same on steam forum and got Dev reply, that they are making new version.
This version is from July 2018 - I hope you are right and the new version will find its way to GOG...
Still no update -_-
Still no update and I think they will never fix this...
avatar
hyperbolix: Still no update and I think they will never fix this...
I already put this game in my shopping cart and I am glad to check the reviews and the forum before buying the game. Too bad the author doesn't care about Linux users....
I did not see this game before and was caught by the graphics ... really nice art and good game play
(as long as it is currently possible due to this bug).
And I can confirm that the game is unplayable under GNU/Linux in the current state (1_3_22787).

As I hope for some miscommunication I asked the support of Alientrap Games on 25. July 2020
to provide information about the problem and when they hope to bring a new version to GOG.

I will add news below when I find or get them ...

JMB

20200725: I was mislead by the GOG product page - Apotheon has both a 32 and a 64 bit binary,
so the given libs are no longer necessary (thus the GOG product page must be updated ...
like so many other ones ...).
And of cause both versions show this bug of a "black screen".
On Steam, the bug is described here:
https://steamcommunity.com/app/208750/discussions/0/1745644671663367553/
thus this bug is shared by Linux and macOS ... (it's "Microsoft.Xna.Framework" ;).

20200110: As no reaction from Devs in 2.5 months I contacted GOG support.
-> Asking to provide an old version without the bug was answered with:
   "Sadly we can't provide an older Linux build as we no longer have them for this title."
-> After some communications Product Team confirmed that it is broken on Ubuntu 18.04 LTS
   and deleted that version from product page.
-> As this was not what I whished for I asked for GOG to contact devs and ask for an upgrade with a playable version.
-> Additionally I sent in sysrep for Ubuntu 16.04 LTS and asked for confirming broken game here.
-> The ticket is about to get closed - no deletion of Linux port - no info about contacting devs -
   only thing was offering refund which should be the last step after deleting Linux on product page.

**** TO ALL GNU/Linux USERS WITH APOTHEON **** REQUEST FOR HELP ***
1) Could anyone who is able to play the current version of Apotheon: 1.3 (22787) could leave a comment
   in this thread about the configuration - in case the screen is not black when entering a room?
   I am convinced that no GNU/Linux solves the bug and that it is just the binary ...
2) If someone has an older version - even though maybe only 32 bit but working -
   may provide this to GOG support to put this in Goodies for those who want to play it?
Post edited October 13, 2020 by JMB9
Great. I played it few years ago and made some progress so it wasn't always broken. But back then I was unable to make controller work with this and gave up on second boss or something. Now controller works but game is unplayable haha.
I accidentally repost. can someone del this post. I can't. sorry and ty.
Post edited January 01, 2021 by Uvhash