It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Found this: - One of the posts describes how to enable the D-pad, so credit goes to one of the posters there. As a DOSBox novice I wasn't aware of this trick, so I thought I'd save anyone else who is having problems with the Xbox controller the trouble of posting the question.

(For those who know their way around DosBox and Config files somewhat).

Config file > Joystick=fcs > Go to DOSBox Keymapper and map the keyboard arrow keys to your D-Pad > Make sure Joystick is enabled in-game (Main Menu/Pause Screen).

(For those not used to DOSBox and its keymapper).

What you need to do first before you start the game is go to the DOSBox config file (dosbox_alienrampage) in the game's directory (typically located at C:\GOG Games\Alien Rampage).
In the config file, look for the line "joysticktype=". By default, it should read like this: joysticktype=auto.
Change it to the following: joysticktype=fcs. Now save these changes and boot up the game.

Next, you need to access the DOSBox keymapper by pressing Ctrl and F1 simultaneously. You'll see a screen with an image representing a keyboard. Using the mouse pointer, click one of the on-screen keyboard arrow keys; for example, the 'Right' Arrow Key, then click 'Add' (located near the bottom of the screen). Now simply press 'Right' on your controller's D-Pad. You've just assigned the function of the keyboard's Right Arrow key to D-pad-Right. Repeat this process until you've assigned all the arrow keys to the corresponding controller D-pad buttons.
Click 'Save' (bottom right of keymapper screen). Your game will resume.

Finally, in the game's menu, make sure 'Joystick' is set to 'Enabled'. You'll now be able to move using the D-pad!
That's it. All done. Enjoy!

Note: If you want to change the other buttons such as for Jump, Shoot etc. I recommend doing so using the game's own options screen - and NOT DOSBox's keymapper - as using keymapper to do this tends to mess these buttons up for some reason.
Post edited August 12, 2017 by RetroCodger426
Thank you!
I have no Idea about DosBox, so this is very helpfull!
Personally I'm a fan of just disabling the joystick in dosbox config and then using to to do the mapping. At least when "digital" style control is good enough.