It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I was in the Kenget Kamulos guild, the part where they keep coming until you surrender. After the Nth battle (I sat at it for hours, fighting, picking items, moving stuff around to get more inventory space/carrying capacity), when the battle started, the game sort of froze, the mouse cursor was moving, but only along the top of the screen (horizontally), and the game didn't react to f.ex. ESC key to open the menu.

I closed it for now (not exactly looking forward to doing it all again, but whatever), so no rush with answering, but did anyone have it happen, and if so, how did you handle it? I -REALLY- don't want it to happen again, there's only so many times I'll be willing to repeat it (Especially as I only picked Khunag before the guild, and while fighting the Kengets over and over I got him from level 8 to about 20, maxxing his Thunderstorm spell too... and now I'll have to do it all again. Ouch).

Edit: I tried again, and it happened again. Not willing to do it a third time before I can get it solved (made a support ticked to see if GOG staff can help). Anyway, after doing the grind twice (without the possibility of a save during it, no less), and the game freezing on me twice, destroying it all, I feel fully justified using some sort of cheat for a lot of in-game money.. Does anyone know one like that? (I know about talking to the healer in Jirinaar or what the city's name was, but that's not what I'm thinking about, it'd take too long anyway - what I'm looking for is some easy and quick cheat for a lot of money - a save editor would do as an option, too).
Post edited September 30, 2016 by piranha1
I was grinding the endless battles in Khamulon and encountered what may have been the same bug? After some time my cursor glitched out and attempting to move it down from the top of the screen wouldn't work, but it seems like that was only half-true. Whilst it appeared that the cursor was at the top of the screen it seems that really it was at the bottom and the game was just visually warping it to appear at the top.

Trying to pull the cursor down wouldn't work (since actually there wasn't anywhere for it to go in that direction) but pushing it up would make it reappear just above the bottom of the screen. I played the rest of those fights with the cursor glitched out. It wasn't ideal but it was workable. So yeah, if anyone else encounters a bug like this try moving the cursor up, because whilst it might look like it's at the top of the screen it might actually be at the bottom.

There might have also been a bit of over-sensitivity moving the mouse, but the visual glitch was the main issue to deal with up until I got to a point where I could save and relaunch the game.
Post edited May 29, 2023 by robertskitch
Okay, I replayed the Khamulon grind to see if I could get the bug to repeat and after about 82 fights my cursor did bug out again, so it seems like a fairly repeatable bug on that section of the game. I talked with the people on the Albion Discord and it was suggested that the bug was probably a DOSBox one, so other versions of the game shouldn't be affected by it.

If it was the same bug as the OP encountered then it's not all that gamebreaking. I was able to play through it and it seemed to actually fix itself after a while. I will say that if you do encounter the bug then just push the cursor up whenever it warps to the top of the screen and it should reappear at the bottom. I think that trying to pull the cursor down from the top of the screen might actually make the bug worse as you will have to push the cursor up for longer to get it to reappear where it should.