It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I managed to somehow stick myself in a wall, and wanted to use Dev/Producer Mode to get out. However, while I can enable cheats ("schnosm " in the options menu) in the normal manner, dev mode (Alt-F12) just seems to play an odd noise and doesn't activate it.

I find it odd, because the Alt-F1-F11 codes work, just not that one. Was it broken intentionally?
Post edited September 14, 2015 by jpublic
avatar
jpublic: I find it odd, because the Alt-F1-F11 codes work, just not that one. Was it broken intentionally?
I don't know if it got broken intentionally, but I've never got the dev mode to work in the retail edition either (and I've playing that one since 1997). Which is a real pity, because there are some secret rooms in two of the later dungeons which I've no idea how to enter.
Technically it's not broken, but Alt-F12 is mapped by DosBox to "Unlock speed (turbo button)" by default.
To use Alt-F12 in Albion you need to unmap it (in DosBox) or remap some other key combination to Alt-F12 (I never tried either, so don't ask me how).

Or as an alternative you can try the unofficial Windows/Linux port - it should work there. I can't post links, but it's mentions in the thread "Lets play Albion (Linux, native)" for example.
avatar
RP1: Technically it's not broken, but Alt-F12 is mapped by DosBox to "Unlock speed (turbo button)" by default.
I didn't think of that.

I've changed "Unlock speed" to Ctrl-Alt-F12 in the keymapper and dev mode works now. Thank you very much. :)

Now I'm just no longer sure, if I actually tried using the dev mode while I was still playing the game under DOS, or only after I've moved on to DOSbox. <.<