It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

As title states, I cannot install Alan Wake's American Nightmare. I first tried it a couple of weeks ago via a pirated installer, and it just froze and ate all my RAM (usage 90%+), I thought maybe something was wrong with the torrent or something like that so I just dismissed it. Now, a couple of weeks later, I bought the game, downloaded it via downloader, and tried to install it. Same thing. Ram usage jumps to around 90%, the installer never shows up, and my whole computer goes really sticky until I force a shutdown/reboot.

I had no problems whatsoever at any point with the original Alan Wake game, so what gives?
Post edited May 29, 2012 by jolssoni
At which point does the installer hang? Does it pass the integrity check or not? Also, try to verify the MD5 hash with the ones found in the gogwiki page. Also, since the installer is a 2.0GB exe file, your real-time antivirus will obviously go nuts checking it before allowing it to run.
Lastly, do a complete scan of your computer, it is quite possible that you picked something up from the shadier corners of the net.
The integrity check never shows up, even when I tried running it with no Antivirus or firewall on.
jolssoni: The integrity check never shows up, even when I tried running it with no Antivirus or firewall on.
Did you check the MD5 hash to see if the file is correct or if it has become corrupted? Also, is the installer the one that is eating all your memory, or another file? Main difference of the American Nightmare setup file is that it is 1 huge executable instead of 1 small executable and a few huge binaries, thus the reason to suspect the Antivirus messing up.
Grab an MD5 hash checker, and compare your file's hash to the one in the gogwiki page linked in post2.
Okay I got it now, it was my Zonealarm firewall after all, it ate up around 1.6GB of RAM out of my four, propably trying to stop the installer from running or something. Thanks for the help anyways! :)