It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I've tried all the compatability modes I can think of, as well as setting it as adminstrator, but nothing works, I always get the same error:

No Label

OS: Windows NT 6.0 (Build: 6000)
CPU: GenuineIntel PentiumPro-class prNVIDIA GeForce G210 (1106)
Video: NVIDIA GeForce G210 (1106)

General protection fault!

I've tried uninstalling and reinstalling it, and that doesn't work either. Any help would be greatly appreciated.
No posts in this topic were marked as the solution yet. If you can help, add your reply
That sounds like a memory issue.

I can only advise you that the game does work on Windows 7 64-bit - I have the original retail version and it works fine, so it's not related to the OS.
First make sure Windows files are up-to-date, GPU drivers, DirectX etc..

I'm not sure if you fixed it but I remember having this issue for some other game. It could be something related to either security or access so try and see if you can add the .exe file for Advent Rising to DEP exception list. Write 'adjust' in search then pick 'adjust the appearance or performance for windows' then go to Data Execution Prevention. If it doens't accept the DEP it's not that.

Also try admin rights.
Take a look at this thread, might help you out or might proof useful for other users.
Post edited January 29, 2014 by Zurvan7