It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Every time i click the 'options' button on the main menu the game will crash to desktop with a standard App Crash windows 7 find solution/report box.
"
Problem signature:
Problem Event Name: APPCRASH
Application Name: SpellForce.exe
Application Version: 0.0.0.0
Application Timestamp: 43bd2a59
Fault Module Name: StackHash_e98d
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Code: c0000005
Exception Offset: 00000000
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 2057
Additional Information 1: e98d
Additional Information 2: e98dfca8bcf81bc1740adb135579ad53
Additional Information 3: 6eab
Additional Information 4: 6eabdd9e0dc94904be3b39a1c0583635
"
i need to change the options, especially resolution as the game looks like trash on my 28" screen at the default resolution its displaying.
none of the other buttons cause a crash. just options.
have tried XP SP3,XP SP2, Vista SP2, Disable Desktop Composition, Run As Administrator on the compatibility options. none work.
Windows 7 32bit Ultimate.
q8400
4gb
radeon 4890 9.11 drivers
Post edited December 13, 2009 by custardcream
This question / problem has been solved by Namurimage
avatar
custardcream: well the game doesnt crash per se. it just doesnt start, as soon as you double click the exe a box appears on screen saying something about an invalid resolution was set and the game cannot be started.
no reason my radeon 4890 cant display 32bit colour.
my desktop is set to true colour 32bit before and after running the game.
weird problem.
edit - the game is indeed running in 16bit colour mode @ 1600x1200.

It is weird.
Maybe take a look in the ATI CCC to see if it's enforcing some setting that should be handled by the application ? Or maybe try creating a game profile for Spellforce with tweaked settings, in case you don't want to mess up your global graphics settings (for all the other games) ?
A search on the official forums reveals that this crash is caused by background programs, ATI tray tools and Bitdefender in particular.
I had this same problem and read about how to start the game windowed in another GOG post.

Anyway, I made a shortcut to spellforce.exe, then right-clicked and chose properties, then added "-window" to the end of the Target: e.g. C:\games\Spellforce -window

With the game running windowed, I was able to click on options without having it crash. When I was done with the options I hit "apply" and config.lua was created in the game directory. I then started the game without the -window option.

Alternatively, just keep playing in windowed mode but edit config.lua and add the following lines (edited to suit your needs of course):

WindowWidth = 1024,
WindowHeight = 768,

FWIW
Post edited November 21, 2011 by noabody