It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Every time i click the 'options' button on the main menu the game will crash to desktop with a standard App Crash windows 7 find solution/report box.
"
Problem signature:
Problem Event Name: APPCRASH
Application Name: SpellForce.exe
Application Version: 0.0.0.0
Application Timestamp: 43bd2a59
Fault Module Name: StackHash_e98d
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Code: c0000005
Exception Offset: 00000000
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 2057
Additional Information 1: e98d
Additional Information 2: e98dfca8bcf81bc1740adb135579ad53
Additional Information 3: 6eab
Additional Information 4: 6eabdd9e0dc94904be3b39a1c0583635
"
i need to change the options, especially resolution as the game looks like trash on my 28" screen at the default resolution its displaying.
none of the other buttons cause a crash. just options.
have tried XP SP3,XP SP2, Vista SP2, Disable Desktop Composition, Run As Administrator on the compatibility options. none work.
Windows 7 32bit Ultimate.
q8400
4gb
radeon 4890 9.11 drivers
Post edited December 13, 2009 by custardcream
This question / problem has been solved by Namurimage
Did you install to default program files folder? If so try reinstalling to something like C:\games\, couldn't hurt to redownload the game again just to make sure it downloaded correctly, if you have the bandwidth where this wouldn't be a problem.
avatar
Ralackk: Did you install to default program files folder? If so try reinstalling to something like C:\games\, couldn't hurt to redownload the game again just to make sure it downloaded correctly, if you have the bandwidth where this wouldn't be a problem.

i installed it to e:\program files\gog.com\......
why would i have to download it again when the file/s contains a file integrity check (which it passes) ?
ive since tried installing to 'c:\games\.....'. and 'c:\program files\gog.com\........'
clicking the 'options' button will still cause the game to crash. giving the exact same error message, as listed above, each time.
at this moment, without being able to set my own game options, this game is unplayable for me.
Post edited December 13, 2009 by custardcream
avatar
custardcream: i installed it to e:\program files\gog.com\......
why would i have to download it again when the file/s contains a file integrity check (which it passes) ?

Is your OS installed to your E drive? As for downloading if it passed the integrity check it should be fine.
Edit: Just noticed your edit above me after posting. Does the game store its options settings in config or ini files that you can access with notepad?
Post edited December 13, 2009 by Ralackk
avatar
custardcream: i installed it to e:\program files\gog.com\......
why would i have to download it again when the file/s contains a file integrity check (which it passes) ?
avatar
Ralackk: Is your OS installed to your E drive? As for downloading if it passed the integrity check it should be fine.

see my edited post just above yours.
my os is on C. which i keep for important stuff. gog stuff and other older games go on D, E, F, G etc drives depending on which has the most free space at the time of installation.
avatar
custardcream: my os is on C. which i keep for important stuff. gog stuff and other older games go on D, E, F, G etc drives depending on which has the most free space at the time of installation.

I'm probably way off here but i'm going to ask anyway.
Do you have an LG monitor ? How about a software called forte manager ?
avatar
custardcream: my os is on C. which i keep for important stuff. gog stuff and other older games go on D, E, F, G etc drives depending on which has the most free space at the time of installation.
avatar
Namur: I'm probably way off here but i'm going to ask anyway.
Do you have an LG monitor ? How about a software called forte manager ?

nope its a hanns g 28in monitor. never heard of forte manager
avatar
custardcream: i installed it to e:\program files\gog.com\......
why would i have to download it again when the file/s contains a file integrity check (which it passes) ?
avatar
Ralackk: Is your OS installed to your E drive? As for downloading if it passed the integrity check it should be fine.
Edit: Just noticed your edit above me after posting. Does the game store its options settings in config or ini files that you can access with notepad?

not that i can find. i know there is one called config.lua thats created because someone mentioned it ages ago when i asked about widescreen options. but ive never actually been able to find it, its not in the games directory and searching for it via start menu doesnt give any results either.
Post edited December 13, 2009 by custardcream
avatar
custardcream: not that i can find. i know there is one called config.lua thats created because someone mentioned it ages ago when i asked about widescreen options. but ive never actually been able to find it, its not in the games directory and searching for it via start menu doesnt give any results either.
Here's my config.lua. It's inside the .rar file, so you'll have to extract it.

Maybe try downloading it, then edit it to adjust to your resolution and place it in your game folder. Think it's worth a shot ?

The resolution on my config.lua is set to 1600x1200, so maybe try to boot the game once before editing the file to see if going to options still crashes the game.
Post edited September 23, 2011 by Namur
avatar
custardcream: here's my config.lua. It's inside the .rar file, so you'll have to extract it.
Maybe try downloading it, then edit it to adjust to your resolution and place it in your game folder. Think it's worth a shot ?
The resolution on my config.lua is set to 1600x1200, so maybe try to boot the game once before editing the file to see if going to options still crashes the game.
avatar
Namur: thanks for the file dude.
where exactly do i put the file on my hard drive? inside the spellforce game directory, or my documents etc??
i have a bit more information for this mystery.
i played a few seconds of the campaign just to the point where i could save.
a directory called 'spellforce' was created in the documents folder.
inside was this log file.....
"
----------------------------
SpellForce 12/13/09 22:08:33
----------------------------
OS Information
--------------
Type : Professional
Build : 7600
MEM Information
---------------
Load : 24
TPhysic : 2147483647
APhysic : 2147483647
TPage : -1
APage : -1
TVirt : 2147352576
AVirt : 2071658496
CPU Information
---------------
Vendor : GenuineIntel
Name : Pentium(R) III processor
Type : 0
Family : 6
Model : 7
Stepping: 2
Speed : 2633 Mhz
PerfFreq: 2609013.000000
ScPerClk: 0.000000
FFLAGS : bfebfbff
FPU : y
VIM EXT : y
DBG EXT : y
PSE : y
MSR : y
PAE : y
MCE : y
CX8 : y
APIC : y
SEP : n
MTRR : y
PGE : y
MCA : y
CMOV : y
PAT : y
PSE36 : y
CLFSH : y
DS : y
ACPI : y
MMX : y
FXSR : y
SSE : y
SSE2 : y
64BIT : n
AMD : y
AMD EXT : n
AMD MME : n
Intel HT: n
PhysProc: 4
LoglProc: 1
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][App]: Version 1.54.75000
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
GFX Information
---------------
resolution : x:1024 y:768 d:16 v:1 m:-1 t:0 a:0 w:0
driver : atiumdag.dll
description : ATI Radeon HD 4800 Series
product : 8
version : 14
subversion : 10
build : 708
vendor id : 1002 (ATI)
device id : 9460
subsys id : 22811787
whql signed : no (warning: the current graphic card driver is not whql certified!)
memory : -1756364800
ps avail : yes
ps version : 3.0
cube mapping: yes
max textures: 8
dxt1 : yes
dxt2 : yes
dxt3 : yes
dxt4 : yes
dxt5 : yes
argb1555 : yes
argb565 : yes
rgba8888 : yes
rgba4444 : yes
rendertarget: yes
bb color : yes
bb depth : yes
volumetex : yes
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][LUA]: -- INITIALIZING DRW DrwLibraryInit.lua
[INFO][LUA]: -- INITIALIZING SOUNDS DrwSound.lua
[INFO][LUA]: -- INITIALIZING EFFECTS object_effect_*.lua
[INFO][LUA]: SOUND MISSING spell_melee_shiftlife
[INFO][LUA]: SOUND MISSING spell_melee_riposte
[INFO][LUA]: SOUND MISSING spell_melee_criticalhits
[INFO][LUA]: 36 ResolveWhite userdata(21): 05A20C70
[INFO][LUA]: 36 ResolveWhite userdata(21): 05A20C70
[INFO][LUA]: 36 ResolveBlack userdata(21): 05A20BA0
[INFO][LUA]: 36 ResolveBlack userdata(21): 05A20BA0
[INFO][LUA]: 36 ResolveBlack userdata(21): 05A20BA0
[INFO][LUA]: 36 ResolveBlack userdata(21): 05A20BA0
[INFO][LUA]: 36 WaveFire userdata(21): 05C02A10
[INFO][LUA]: 36 WaveFire userdata(21): 05C02A10
[INFO][LUA]: 36 WaveFire userdata(21): 05C02A10
[INFO][LUA]: 36 WaveFire userdata(21): 05C02A10
[INFO][LUA]: 36 WaveIce userdata(21): 05C033D0
[INFO][LUA]: 36 WaveIce userdata(21): 05C033D0
[INFO][LUA]: 36 ResolveEarth userdata(21): 05A20DA8
[INFO][LUA]: 36 ResolveEarth userdata(21): 05A20DA8
[INFO][LUA]: 36 ResolveMental userdata(21): 05A20C08
[INFO][LUA]: 36 HeadShock userdata(21): 058A7400
[INFO][LUA]: 36 ResolveMental userdata(21): 05A20C08
[INFO][LUA]: 36 ManaOut userdata(21): 05C01078
[INFO][LUA]: 36 ResolveMental userdata(21): 05A20C08
[INFO][LUA]: 36 CharmChain2 userdata(21): 09CE1D28
[INFO][LUA]: SOUND MISSING spell_hit_mutation replaced by spell_hit
[INFO][LUA]: SOUND MISSING spell_hit_mutation replaced by spell_hit
[INFO][LUA]: 36 ResolveBlack userdata(21): 05A20BA0
[INFO][LUA]: SOUND MISSING spell_hit_mutation replaced by spell_hit
[INFO][LUA]: 36 ResolveBlack userdata(21): 05A20BA0
[INFO][LUA]: SOUND MISSING spell_hit_vodoo replaced by spell_hit
[INFO][LUA]: -- INITIALIZING BUILDINGS object_building_init.lua
[INFO][LUA]: -- INITIALIZING EQUIPMENT object_equipment_init.lua
[INFO][LUA]: MISSING FILE: 7406 equipment_weapon_shield_gold1
[INFO][LUA]: MISSING FILE: 7407 equipment_weapon_shield_flipped_gold1
[INFO][LUA]: MISSING FILE: 7408 equipment_weapon_shield_gold2
[INFO][LUA]: -- INITIALIZING NATURE object_nature_init.lua
[INFO][LUA]: -- INITIALIZING RESOURCES object_resource_init.lua
[INFO][LUA]: -- INITIALIZING BLENDING object_blending_init.lua
[INFO][LUA]: -- INITIALIZING FIGURES object_figure_init.lua
[INFO][LUA]: MISSING ANIMATION: figure_npc_kithar_resolveenemy
[INFO][LUA]: MISSING ANIMATION: figure_npc_kithar_resolveenemy
[INFO][LUA]: MISSING ANIMATION: figure_npc_kithar_cast
[INFO][LUA]: MISSING ANIMATION: figure_npc_headtoucher_resolveenemy
[INFO][LUA]: MISSING ANIMATION: figure_npc_headtoucher_resolveenemy
[INFO][LUA]: MISSING ANIMATION: figure_npc_headtoucher_cast
[INFO][LUA]: MISSING ANIMATION: figure_npc_muscleman_rightswordempty2
[INFO][LUA]: MISSING ANIMATION: figure_npc_muscleman_rightmaceshield1
[INFO][LUA]: MISSING ANIMATION: figure_npc_muscleman_rightmaceempty2
[INFO][LUA]: MISSING ANIMATION: figure_npc_muscleman_rightstaff1
[INFO][LUA]: MISSING ANIMATION: figure_npc_muscleman_bothsword1
[INFO][LUA]: MISSING ANIMATION: figure_npc_muscleman_bothsword2
[INFO][LUA]: MISSING ANIMATION: figure_npc_muscleman_rightstaff1
[INFO][LUA]: MISSING ANIMATION: figure_npc_muscleman_rightswordempty2
[INFO][LUA]: MISSING ANIMATION: figure_npc_muscleman_rightmaceempty2
[INFO][LUA]: MISSING ANIMATION: figure_npc_muscleman_bothstaff1
[INFO][LUA]: MISSING ANIMATION: figure_npc_muscleman_righthand1
[INFO][LUA]: MISSING ANIMATION: figure_npc_muscleman_rightstaff1
[INFO][LUA]: MISSING ANIMATION: figure_npc_muscleman_idlewar
[INFO][LUA]: MISSING ANIMATION: figure_boss_belial_idlespecial1
[INFO][LUA]: MISSING ANIMATION: figure_boss_dryade_resolveenemy
[INFO][LUA]: MISSING ANIMATION: figure_boss_dryade_resolveenemy
[INFO][LUA]: MISSING ANIMATION: figure_boss_dryade_die
[INFO][LUA]: MISSING ANIMATION: figure_boss_dryade_hit1
[INFO][LUA]: MISSING ANIMATION: figure_boss_dryade_hit2
[INFO][LUA]: MISSING ANIMATION: figure_boss_dryade_hit3
[INFO][LUA]: REDUCED ANIMATION 3765 wing_test wing_test_idle nil
[INFO][LUA]: OVERLOADING FIGURE 30
[INFO][LUA]: DrwLibraryInit done.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][LUA]: -- INITIALIZING SOUNDS DrwSound.lua
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file config.lua. Default values used.
[INFO][UTL]: Error reading the config file DrwDebugInfo.lua. Default values used.
[INFO][CON]: Registered Objects: AStar, Adorn, AppSession, Atmosphere, Building, BuildingToolBox, Camera, DebugInfo, Effect, Figure, FigureJobs, FigureToolBox, GameControl, GameView, GdMain, GdsMain, Illumination, InfluenceMap, Lake, Lightmap, Object, ObjectLibrary, Ocean, Player, Render, Selection, Sky, Spell, Terrain, UnExplored, World, WorldToolBox
[INFO][CON]: -- INITIALIZING SOUNDS DrwSound.lua
[INFO][CON]: -- INITIALIZING EFFECTS object_effect_*.lua
[INFO][CON]: SOUND MISSING spell_melee_shiftlife
[INFO][CON]: SOUND MISSING spell_melee_riposte
[INFO][CON]: SOUND MISSING spell_melee_criticalhits
[INFO][CON]: 36 ResolveWhite userdata(68): 112548F8
[INFO][CON]: 36 ResolveWhite userdata(68): 112548F8
[INFO][CON]: 36 ResolveBlack userdata(68): 11254828
[INFO][CON]: 36 ResolveBlack userdata(68): 11254828
[INFO][CON]: 36 ResolveBlack userdata(68): 11254828
[INFO][CON]: 36 ResolveBlack userdata(68): 11254828
[INFO][CON]: 36 WaveFire userdata(68): 05C01DE0
[INFO][CON]: 36 WaveFire userdata(68): 05C01DE0
[INFO][CON]: 36 WaveFire userdata(68): 05C01DE0
[INFO][CON]: 36 WaveFire userdata(68): 05C01DE0
[INFO][CON]: 36 WaveIce userdata(68): 1108D108
[INFO][CON]: 36 WaveIce userdata(68): 1108D108
[INFO][CON]: 36 ResolveEarth userdata(68): 11254A30
[INFO][CON]: 36 ResolveEarth userdata(68): 11254A30
[INFO][CON]: 36 ResolveMental userdata(68): 11254890
[INFO][CON]: 36 HeadShock userdata(68): 058A6970
[INFO][CON]: 36 ResolveMental userdata(68): 11254890
[INFO][CON]: 36 ManaOut userdata(68): 1108B6A0
[INFO][CON]: 36 ResolveMental userdata(68): 11254890
[INFO][CON]: 36 CharmChain2 userdata(68): 09CDE4B0
[INFO][CON]: SOUND MISSING spell_hit_mutation replaced by spell_hit
[INFO][CON]: SOUND MISSING spell_hit_mutation replaced by spell_hit
[INFO][CON]: 36 ResolveBlack userdata(68): 11254828
[INFO][CON]: SOUND MISSING spell_hit_mutation replaced by spell_hit
[INFO][CON]: 36 ResolveBlack userdata(68): 11254828
[INFO][CON]: SOUND MISSING spell_hit_vodoo replaced by spell_hit
[INFO][CON]: Registering ConDebug.lua debugging functions...
[INFO][CON]: Registering GdsVariables.lua console set variable functions...
"
**********************************************************************************************
as you can see, its littered with unable to read or locate config.lua errors.
config.lua doesnt exist and the installer nor the game creates it.
i think the game crashes because its either trying to create it, and cannot, or its trying to access it... gets confused and nukes itself.
edit - putting the config.lua, uploaded by namur, into the same directory where the spellforce save folder is located doesnt not make any difference. the game will crash when trying to access options.
Post edited December 13, 2009 by custardcream
avatar
custardcream: edit - putting the config.lua, uploaded by namur, into the same directory where the spellforce save folder is located doesnt not make any difference. the game will crash when trying to access options.

The config.lua goes in the game folder, not in the saves folder.
if you installed to default loction should be
C:\Program Files\GOG.com\Spellforce - Platinum Edition
or
C:\program Files (x86)\GOG.com\Spellforce - Platinum Edition
if you're using a 64 bit OS.
avatar
custardcream: The config.lua goes in the game folder, not in the saves folder.
if you installed to default loction should be
C:\Program Files\GOG.com\Spellforce - Platinum Edition
or
C:\program Files (x86)\GOG.com\Spellforce - Platinum Edition
if you're using a 64 bit OS.
avatar
Namur: i tried putting it in the game folder. the game still crashes when you click the options button.
i dont know what resolution you set the game to, but i get an error message saying the resolution doesnt exist unless i set the resolution number to 8 instead of 9.
i have a max resolution of 1920x1200
edit - in your config file, is the game set to the maximum settings. all sliders at max etc?
Post edited December 14, 2009 by custardcream
avatar
custardcream: i tried putting it in the game folder. the game still crashes when you click the options button.
i dont know what resolution you set the game to, but i get an error message saying the resolution doesnt exist unless i set the resolution number to 8 instead of 9.
i have a max resolution of 1920x1200
edit - in your config file, is the game set to the maximum settings. all sliders at max etc?

The game in that config file is set to the max resolution you can get from the options menu, 1600X1200. You can get other resolutions to work by editind the config.lua file.
You can see the details on how to do that on this post.
btw, i'm also using 1920X1200 on my monitor (24'' LCD)
And yes, everything is maxed out on that one. If you want to try with lower settings here's what the Graphic section looks like after turning some of the graphic options off/down.
Graphic =
{
AvoidExcessiveFrameBuffering = 0,
VSync = 1,
FlatShades = 1,
EffectLightmap = 0,
EnvironmentMapping = 0,
AdornMode = 1,
ObjectFadeDistance = 75,
ShadowType = 0,
TextureQuality = 2,
Filtering = 0,
ScreenResolution = 9,
}
Also, i forgot to tell you that if you have the game installed to the default Program Files directory on Win7, you should try to move the config.lua file from the game folder to:
C:\Users\<your_username_here>\AppData\Local\VirtualStore\Program Files (x86)\GOG.com\Spellforce - Platinum Edition
to see if it makes a difference. Win7 is touchy about stuff installed on Program Files
Post edited December 14, 2009 by Namur
ive installed on E: for now. i dont want games on my boot drive if necessary.
glad that the options are maxed in your config.lua. my gfx card can easily handle the game maxed.
if i recall higher resolutions are only available in windowed mode... which will give a border. i think ill stick with 1600x1200.
options still doesnt work, but at least your config has helped.
avatar
custardcream: ive installed on E: for now. i dont want games on my boot drive if necessary.
glad that the options are maxed in your config.lua. my gfx card can easily handle the game maxed.
if i recall higher resolutions are only available in windowed mode... which will give a border. i think ill stick with 1600x1200.
options still doesnt work, but at least your config has helped.

I'm glad the file helped with the resolution, but it's a pitty the game still crashes.
In any case, if you want any other options tweaked, gameplay or interface and you're unsure what values to use, let me know and i'll post a list of the available options and the necessary values to edit the config.lua accordingly.
Just a thought, you say the game crashes with resolution set to 9 but not set to 8.
They're both 1600x1200, the difference being 32 bit color (9) and 16 bit color (8). I don't know if that's relevant or not to your problem, but maybe make sure you're desktop is not stuck in 16 bit color mode...
avatar
custardcream: ive installed on E: for now. i dont want games on my boot drive if necessary.
glad that the options are maxed in your config.lua. my gfx card can easily handle the game maxed.
if i recall higher resolutions are only available in windowed mode... which will give a border. i think ill stick with 1600x1200.
options still doesnt work, but at least your config has helped.
avatar
Namur: Just a thought, you say the game crashes with resolution set to 9 but not set to 8.
They're both 1600x1200, the difference being 32 bit color (9) and 16 bit color (8). I don't know if that's relevant or not to your problem, but maybe make sure you're desktop is not stuck in 16 bit color mode...

well the game doesnt crash per se. it just doesnt start, as soon as you double click the exe a box appears on screen saying something about an invalid resolution was set and the game cannot be started.
"[TERMINATION] UTL_QuickIntegrator::CreateDisplay()
Desired resolution not found. Please install latest drivers!
"
^Thats what the error log says when attempting 1600x1200 @32bit (screen resolution =9)
no reason my radeon 4890 cant display 32bit colour.
my desktop is set to true colour 32bit before and after running the game.
1280x1024@32bit works fine in the game (screen resolution=7)
weird problem.
edit - the game is indeed running in 16bit @ 1600x1200 using option 8.
Post edited December 14, 2009 by custardcream