It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
I installed Duke Nukem Manhattan Project on my new computer with Windows 7 64 bit . When I pressed the ~ (tilde) key to access the console, nothing happened. I thought it might have something to do with the install so I uninstalled the game, reinstalled it and I am experiencing the exact same problem.
It's not the keyboard because I tried a different one and as you can see a ~ displays when I press the key.
It worked fine when it was installed on my old computer running Windows XP.
Is there any body else out there experiencing this same type of trouble?
This question / problem has been solved by Vorticonimage
avatar
Vorticon: UPDATE: Well now I'm really disappointed. I was able to install DNMP on another Windows 7 64 bit computer and low and behold the console DOES work. And it's a plain jane eMachine to add insult to injury. I tried swapping keyboards and it has no effect on the problem.
Very, Very strange situation. At this point I don't think I'm going to find a solution.

Have you installed any keyboard software on your Win 7 machine?
avatar
Vorticon: UPDATE: Well now I'm really disappointed. I was able to install DNMP on another Windows 7 64 bit computer and low and behold the console DOES work. And it's a plain jane eMachine to add insult to injury. I tried swapping keyboards and it has no effect on the problem.
Very, Very strange situation. At this point I don't think I'm going to find a solution.
avatar
korell: Have you installed any keyboard software on your Win 7 machine?

Only the Microsoft Intellitype software for my keyboard. It doesn't have a feature to remap the keys and even if it did I didn't enable it at any time.
Well, re-reading your issue you say you type the ~ key which is placed just to the left of the 1 key. My thoughts are that it might be a regional setting as I have a UK region keyboard and the ~ key is placed next to the Enter key above the right shift button (just like Ralackk said).
Here on GOG it shows myself and Ralackk in the UK whilst you are shown as US, so it may just be region settings.
The button I have to the left of the 1 key is ` so have you tried pressing this button (wherever it is on your keyboard). Note that it is angled and is not the same as '.
Another possible solution could be for you to change your Windows regional settings and keyboard layout to UK and then try the button to the left of the 1 key.
**PROBLEM SOLVED!!**

A few days ago i installed the latest version of DosBox on my machine. I tried to mount my games directory and lo and behold, my keyboard was displaying incorrect characters for the [ ] \ keys. I did a search on Google and found the following...

"If you use the Microsoft eHome remote/receiver (official media centre remote and USB receiver) you'll notice under your device manager you have a new device named Microsoft eHome MCIR 109 Keyboard; this is the cause of the tilde key not working. It also affects your plus, minus, parenthesis, hash, @, and slash keys remapping them to different functions. (some are even weird Kanji characters)

Solution is as follows and will not affect the functionality of your Media Centre remote:

1. Go into Device Manager -> Keyboards.

2. Right-click "Microsoft eHome MCIR 109 Keyboard", choose "Update Driver" ("Update Driver Software" on Vista).

3. Choose "Browse my computer for software" (XP users tell it not to install automatically and say you'll specify the location, then when it asks you where you would like it to search for drivers choose the option to choose from a list) then "Let me pick from a list of device drivers on my computer".

4. Make sure "show compatible hardware" is checked, then select "HID-compliant device" and click next. Click any remaining "OK" or "Finish" buttons after Windows has installed the driver.

By making it use the generic "HID-Compliant Device" driver it still retains whatever function it provided (although when testing I didn't find it gave ANY function, was more of a redundant device), but it will no longer interfere with games or applications which poll input in whatever specific manner causes them to be affected by this bug. Logitech staff might want to add this information to their knowledge base or sticky it somewhere for users of Microsoft's Media Center Remote, as it will affect the G15 adversely in random games/applications otherwise."

Even though I have an HP keyboard, not Logitech, the above solution fixed my problem and now I can use the ~ (tilde) key in the game to access the console.

What is interesting to note is that the keys worked perfectly normal in a Windows environment. It is when typing in a DOS window that the problem occurred.

Anyway, thanks for all the input from the posters in this thread.
Post edited May 25, 2011 by jurijchrul