It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
I am running Duke3d on a Mac and whenever I start the game through Eduke32 the game automatically loads and does not let me tinker with the start window. I am unable to check the the box because it automatically goes to the game and disables the mouse.

Does anyone know how I can fix this?
This question / problem has been solved by Forgeimage
it's been years since i've tinkered with mac, so i don't remember the file extension system.

basically go to the duke directory and edit the file equivalent to eduke32.cfg
and change the line under [setup]
to read: ForceSetup = 1
Post edited January 15, 2013 by Forge
avatar
Forge: it's been years since i've tinkered with mac, so i don't remember the file extension system.

basically go to the duke directory and edit the file equivalent to
and change the line under [setup]
to read: ForceSetup = 1
Awsome! Works perfectly and I am able to run HRP and everything!
I tried this as well, but changing ForceSetup =1 doesn't work for me. Is there a bug with the latest mac eduke32 that prevents it from showing the startup window? I've edited the eduke cfg a bunch of times, but it refuses to show the startup window even if i completely trash the cfg and edit it from scratch.
have you edited the eduke32.cfg file, played the game, then went back and looked to see if the editing you made changed back to what it was before?

if this is the case try editing the eduke32.cfg file to what you want then change the file's properties to "read only" so the game can't change it back to default
avatar
Forge: have you edited the eduke32.cfg file, played the game, then went back and looked to see if the editing you made changed back to what it was before?

if this is the case try editing the eduke32.cfg file to what you want then change the file's properties to "read only" so the game can't change it back to default
That's the strange thing. If I set ForceSetup =1 or = 0 it makes no difference. Eduke doesn't ever change the file on its own, and it still never shows the startup window. Other changes that I make in the eduke32.cfg are recognized (autoload, polymer etc.) I just can't figure out what it might be. If I have no duke3d.grp loaded, I get the warning screen and the startup window in eduke, but the warning screen covers up the startup window and merely forces you to close eduke and reopen with a valid .grp file loaded. So I know it CAN display the startup window, it just refuses to no matter how I edit the cfg file. Any other ideas?
what OS x version are you running & which version of eduke?

you may have to down grade/ up grade to match up requirements

try these pages for info:

http://www.spam-filter.de/osx/eduke32_on_os_x

http://www.spam-filter.de/?ns=osx%2Feduke32%2Farchive&tab_files=files&do=media
avatar
Forge: what OS x version are you running & which version of eduke?

you may have to down grade/ up grade to match up requirements

try these pages for info:

http://www.spam-filter.de/osx/eduke32_on_os_x

http://www.spam-filter.de/?ns=osx%2Feduke32%2Farchive&tab_files=files&do=media
I'm on 10.7.5 and I'm running the latest version of eduke32.

EDuke32 2.0 Universal (Version 2013-01-15, svn3393)

Is there a newer version? Basically, the forcesetup tag in the eduke.cfg is being ignored.

I tried installing the latest (previous?) lion build: eduke32_osx_leopard_svn3381
But that exhibited the same behavior. Even if I select "show setup window at start" while running eduke,and then quitting. It still doesn't show the startup window on restart. Eduke does change forcesetup to 1 or 0 depending on my setting in the program (game setup screen), but it has no effect when I start up eduke again.
Post edited March 20, 2013 by Jottle
Edit: well. Mark this problem as solved, again. On the discussion tab of the eduke mac wiki I found this comment:

"The GUI code for Mac OS X is still work in progress. Right now it is totaly broken on OS X, tho. It worked fine up to SVN 3092 or so. So please be patient .. or write yourself a wrapper script, that calls EDuke32 with the right command line parameters to fire up DukePlus (thats how I do it myself)."

So I downloaded version 3092, and sure enough, it correctly displayed the startup window. I guess that explains the problems I've been having as of late :)
Post edited March 20, 2013 by Jottle