It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Hello,

I can't seem to get the mods to show up in the "Expansions" list. Here's what I did so far:

1) Installed ArmaA 2 (in a different folder from the default)
2) Ran it once as Admin, and then put in the multiplayer serial and ran it again. Still works.
3) Downloaded the CBA files, version 1.0.0 since I'm not using the beta build, I think...?
4) Unzipped the @CBA, @CBA_A2, and @CBA_OA folders into the install directory
5) Added @CBA;CBA_A2;@CBA_OA to the launcher mod options, so that it's -mod=EXPANSION;ca;@CBA;@CBA_A2;@CBA_OA
6) Ran ArmA 2 to see that CBA is not in the Expansions list.

I also tried with just EXPANSION;ca;@CBA in the mods list, but it didn't show up under Expansions, either.

What am I missing?
This question / problem has been solved by zolopimage
avatar
lf: Hello,

I can't seem to get the mods to show up in the "Expansions" list. Here's what I did so far:

1) Installed ArmaA 2 (in a different folder from the default)
2) Ran it once as Admin, and then put in the multiplayer serial and ran it again. Still works.
3) Downloaded the CBA files, version 1.0.0 since I'm not using the beta build, I think...?
4) Unzipped the @CBA, @CBA_A2, and @CBA_OA folders into the install directory
5) Added @CBA;CBA_A2;@CBA_OA to the launcher mod options, so that it's -mod=EXPANSION;ca;@CBA;@CBA_A2;@CBA_OA
6) Ran ArmA 2 to see that CBA is not in the Expansions list.

I also tried with just EXPANSION;ca;@CBA in the mods list, but it didn't show up under Expansions, either.

What am I missing?
Read http://forums.bistudio.com/showthread.php?144058-GOG-com-version-of-Arma-2-Combined-Operations&highlight=gog+mods

I am not sure the exact location in regedit where the registry information is, so do a good amount of google
searching.

EDITED out rant...

EDITED: Maybe they should let the original installers for Arma 2 and Operation Arrowhead run, all the registry information would be done correctly. AS far as I know Sproket works like that, you have to install arma 2 then after its finished, install operation arrowhead. The only issue downloadign the patches, but I can verify that Operation Arrowhead Disc installer did have patches on it (Patched Arma 2 to 1.08), so maybe put the patches on the download list in "my Games" account page.
Post edited February 10, 2013 by zolop
Hi zolop,

Those instructions seem to work for me now that I got the right version of CBA. I tried them earlier with the wrong version of CBA and everything broke and was horrible. Thanks!

I'm really hoping for a way to make this work with the default launcher though, is this possible at all?
avatar
lf: Hi zolop,

Those instructions seem to work for me now that I got the right version of CBA. I tried them earlier with the wrong version of CBA and everything broke and was horrible. Thanks!

I'm really hoping for a way to make this work with the default launcher though, is this possible at all?
Nope, as far as I know. When you create a custom shortcut using and enter all the information in the target line "mod=EXPANSION;ca;@CBA;@CBA_A2;@CBA_OA " you are limited by WINDOWS how many mods you can use because of the limit on characters in that target line UI box.

Need someone to verify that you can enable expansions (what we call mods and addons) in the game Arma 2 CO menu. Try doing that instead of making a shortcut, thats the only other option. I uninstalled the game because I was having some registry issues.
Post edited February 12, 2013 by zolop