It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

BerndWolff: According to the game's entry in GOG Galaxy, it should be possible to switch languages in the game. However I do not find an option to do this (version 1.3.0)

It may just be that I am blind,... has anybody found the setting?

There is no option to change the language in-game. It can only be done by switching the system language.