It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Please check your accounts as we have rolled out a Universal update (version 1.01) for Tomb Raider that includes the famous Tomb Raider Multi Patch from the tombraiderchronicles.com community.

Big thanks go out again to the tombraiderchronicles.com commmunity for allowing us to use the Tomb Raider Multi Patch!
avatar
Tucker8: is it necessary to install the patch even if the games work fine for me?
avatar
gameon: I'd like to know that too
No, if the games work it shouldn't be necessary. The patch mostly provides fixes (from multipatcher, and our own) for problems which were reported on the forum and support.
avatar
manic221: snip
What issues?
avatar
vertex: ...and I'm confused again. This is why:

1. launching the updater
2. klicked apply the update
3. updater tells me my version isn't compatible (red font)
4. trying again, because I wanna post the exact message and had already closed it
5. updater tells me "Update already applied!" (green font)

So.. I guess it's just the "incompatible version" message displayed incorrectly, while everything actually worked fine?
I tested the patch today with a fresh download and install of the Tomb Raider trilogy.

Have you tried redownloading both the installer and the patch? Perhaps something may have gotten corrupted somewhere along the line.
The patch is designed to work with fresh install- 'wrong version' means some files are different and can't be patched. I think this could be caused by setup utility or editing DOSBox conf file, but patch should work after reinstall.
avatar
pfliegerz: Hey - issues I'm having... hopefully someone has ideas. I scoured the forum but couldn't find anything conclusive.

TR 1- Freezes before first FMV sequence... did task manager prompt and it can be played windowed. No big deal.

TR 2- AWFUL color rendering. Bricks show up pink and blue.

TR 3- Won't even launch. It crashes as soon as I double click the .exe. Tried compatibility mode but that didn't work.

Thanks guys!
Try running the Graphic Mode setup utility found in the Start menu item for the game and don't run the executable files directly, use the short cut from the Start menu instead.