It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

cogadh: I bought the game yesterday and after working through a particularly annoying gamepad issue, it played fine. I played for several hours with no issues whatsoever and was having a ton of fun with it, but, eventually I had to sleep. Today, when I try to launch the game, a blank white screen pops up for a brief moment, then just disappears with no error message of any kind (nothing in Event Viewer either). I did update my video card drivers to the latest after playing last night, so the first thing I did was a clean uninstall/reinstall of older drivers, but the same problem still occurs. I did try modifying some of the executable's compatibility settings (run in XP compatibility mode, run as admin), but nothing helped. I'm at a loss here with the stunning lack of meaningful feedback from the game on what is happening, I hope someone else has run into this and found a solution.

System specs:
Windows 10
Core I7 3770 @ 3.4GHz
GeForce GT640 running 372.70 drivers (yeah, I know I need to upgrade the hardware)

EDIT - Further troubleshooting I have done:
Use Galaxy to verify files - Updated 0.2MB of files, no effect on problem
Uninstall/reinstall via Galaxy - No effect on problem
UIninstall/reinstall via backup executable- No effect on problem
Hey Cogadh,

Please send us a Support ticket BUT please do the following:

- mention what you have already done to try and get the game running
- mention whether you have tried installing the game via Galaxy or the offline installers
- don't forget to attach a DxDiag :)

Basically, the more info you give our Support staff as to what you have already tried, the better the chances that we can fix this on our end and you'll avoid the "Please run it as administrator..." responses :)