It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
Rortron: I recently updated my game at the official website and now it is asking for a CD. Is anyone else having this problem?
Hi,

Our version of Restaurant Empire is already at version 1.21, which is the latest possible patch for the game. When you tried to update the game, the update re-introduced the CD check originally in the game and that's why you are now being asked for a CD :D.

Hope that helps :D.