It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
Rododuille: Hello, I just bought The Darkside Detective by Spooky Doorway tonight upon hearing great reviews on the game. I installed it on my Mac OS 10.10.5, but every time I try to play it, the game only directs me to a black screen. There is a pixelated arrow that's obviously the one for the game that I can move, but other than that nothing to be seen. I hear music and background sounds, yet I can't seem to see anything at all in the game.

Is there a reason for this, and if so, how can I fix it? I really want to play this game. I do not want to have to re-download it again.

Thanks for reading.
Hi,

Before the game starts, do you get a launcher window with a bunch of screen resolution sizes?
avatar
JudasIscariot: Hi,

Before the game starts, do you get a launcher window with a bunch of screen resolution sizes?
avatar
Rododuille: No, it didn't give me that option at all. It automatically goes to full screen. It was odd since all the other games I bought and downloaded from GOG had a DMG file, but this one had a pkg or something. I had to install it directly to my Mac, instead of having to drag the game to the application folder.

Is there anything I can do to maybe fix this black screen issue? It's frustrating and quite frankly a waste of my money if I can't even see the game I'm trying to play.
Hey, I found a workaround and the issue but I am confirming some things with our Mac crew so I can give you the proper solution as my Mac knowledge isn't all that great :)
avatar
Rododuille: Thank you, Thank you!

I will be waiting patiently for the fix, since this is one game that I really don't want to miss out on!

I'm not quite sure but I'm suspecting it's my settings and not the game itself. I just don't know how to make it work better.
As of right now, we've asked the developer to re-enable the Unity launcher for the game because the game CAN be played but in fullscreen windowed mode rather than fullscreen mode, which it is set to by default as of right now.

If you want to try and get the game to go into windowed mode for the time being you can try the following steps:

1. Go to ~/Library/Preferences/ and look for a file called thedarksidedetective.plist

2. While you have that directory opened up, open a terminal in that directory.

3. When you have the terminal opened in the ~/Library/Preferences/ directory please type the following command

plutil -convert xml1 thedarksidedetective.plist

This should change the thedarksidedetective.plist file into an XML file that you should be able to edit with just about any text editor. Open up the converted file and look for this section within the file:

<key>Screenmanager Is Fullscreen mode</key>
<integer>1</integer>

See that "1" in between the integer tags? Change that to "0", save the file, and then run the following command in your terminal:

plutil -convert binary1 thedarksidedetective.plist

and then try starting the game again.

You should see the game start in a window and you should be able to maximize the window.
avatar
AbacusWizard: Hello--I am having the exact same issue on Mac OS 10.12.6. I followed your advice by editing the plist file (I tried setting fullscreen mode to 0, and independently also tried editing the screen resolution settings in the same file to match my own monitor), but in all cases when I tried running the game it still did the same thing: just a black screen with a big pixellated white arrow for a cursor, plus eerie music and the sound of a door slamming.

After quitting the program, I tried looking at the plist file again, and found that it had reset to its default values (fullscreen mode to 0, and the original screen resolution settings). Locking the plist file does not seem to prevent this.

Any ideas about what to try next?
Hi,

We've released an update to the game. Please update the game either via Galaxy or download the updated PKG file from your library :)
avatar
Rododuille: Thank you for the helpful tip! It was a whole lot of mess since I didn't know what I was doing anyway, what with all the technical stuff but thank you nonetheless!

I managed to figure out a solution myself. I suspected that the game was working and it was just zoomed in too much, so I did what I thought could work, and it did!

If you're using a Mac version 10.10+, then it's most likely automatically going into full screen the moment you click on the game's icon. Since it's zoomed in too much, you'd have to make the window smaller.

I pressed command+F. This takes it out of the full screen. Now, you can make the window smaller and actually see the game screen.

p.s. After fixing that, sometimes when you turn the game on you'll notice that the game screen is not proportioned correctly (the sides will be cut off, so to speak). Starting a case fixes this issue and you should be fine playing the game.

Again, thank you for all the help!
We've released an updated version of the game, please update either via Galaxy or download the updated PKG file from your library :)
Post edited August 04, 2017 by JudasIscariot
avatar
JudasIscariot: We've released an updated version of the game, please update either via Galaxy or download the updated PKG file from your library :)
avatar
rickricardu: Hi JudasIscariot, I'm having the same issue with all ANOMALY WARZONE EARTH games. Hat I need to do? Can I request an update? Open some ticket?
Thank you!
Hi,

Please open up a Support ticket by following the Support link at the top of the page :)