It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

meisjp: I haven't seen that and don't have an idea at this point. You had a previous version, I assume (ex: 1.03). Perhaps try uninstalling/reinstalling? Your data should be run, though you can always backup to be safe. I don't know the GoG client well - is there a way to validate/delete local like with Steam?
igrino: Hello meisjp,
Unfortunately I am also new to GoG...
However the error is triggered immediately after I launch the installer: it is a sort of self check of the data integrity (of the new downloaded version 1.04 not of the existing one) and, obviously, something goes wrong. So I don't think unistalling/installing helps.
I have tried to download a second time the installer but nothing has changed (same error).
Googling I have found a similar issue for another game:
Hope it helps...
Hi igrino,

Sorry about the md5 error. As of right now, we've retracted the faulty build for version 1.04 and we have replaced it with version 1.03.

To access this build, you will need to go to your library and download it like you did a while ago. Please look for a file called <---- that's the working build for version 1.03.

We will have the updated version fixed on Monday :)
Post edited July 09, 2016 by JudasIscariot