It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
Onlooker: Is anyone else experiencing this? It's fine when you're on the policy screen or whatever it's called (the one with red, white and blue circles), but whenever I go to any of the subscreens (Security, Implement New Policy, Expenditure, etc.), the screen starts flickering like crazy and it's really, really distracting. It flickered all the way through the tutorial at the beginning, too.
Re-download the Linux version as we just uploaded version 1.20. Let us know if this issue goes away with the new version :)