It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Treewyrm: Laptop, Windows 10. Unable to leave keyboard configuration screen, enter on accept settings doesn't do anything (and no, it's not red, no overlapping keybinds), escape button does nothing. How do I enter main menu from game? Esc doesn't do anything there either. Love the art style and animations but on technical side of things seem to be rough around the edges.
Hi there!

I experienced the same issue (controller button press only worked on the first screen, couldn't leave the keyboard configuration screen) and here's what I did to solve it:

1. I checked my PC to make sure i didn't have any additional controllers plugged in. Apparently, I had an old USB plug from a wireless Game-Sir controller (it was an Xbox One controller knock off I thought I would try since it was cheaper than the original lol). In short, please make sure you only have one controller plugged in and only one.

2. After unplugging the extra controller, I checked this directory on my PC C:\Users\<your user name on your PC goes here>\AppData\LocalLow\TheGameKitchen\Blasphemous\Savegames and deleted the following files:


I then restarted the game and let it regenerate its control files (the ones you deleted) and everything worked as advertised.

tl;dr please make sure you only have ONE and only ONE controller plugged into your PC while playing the game and check if your Device Manager doesn't have more than one controller registered. It seems to have trouble recognizing and then choosing which controller you will be using to play the game.
Post edited September 11, 2019 by JudasIscariot