It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I've been having the issue with rainbow colours that some people have reported on the forum. Everything was fine until chapter 4, now I cannot fix it. By restarting my computer I managed to mostly get rid of it, but rainbow remains around the people, my mouse cursor and some objects in the environment, as well as on parts of the menu screen. I've tried all the fixes mentioned in the forum but none of them have worked for me. I'm running Windows 7.

I remember this rainbow effect being a problem when I played the game years ago on my Win98 system. Is there any fix for it?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Hello, you can try Alt + Tab it sometimes clear the colour corruptions.

But the best is this little app :

http://static.macuyiko.com/files/palettestealersuspender/

Works perfect for me, for Fallout 1, Sanitarium and Legacy of Kain
Hi,
just wanted to share what worked for me. I also had the "rainbow colors" glitch, and so far, I mixed and tried almost every solution shared in these forums.

(I'm playing on a laptop under Windows 7 by the way.)

What did it was :

In the game properties :
- Windows 95 compatibility
- "run as administrator" checked
- nothing else checked in the game compatibility pannel
- the "-e" thingy added

- all programs (especially the explorers) closed from the task window
- only the "screen resolution" pannel left open when I launch the game (you can access the pannel from your desktop)

For the moment, that did it ... The colors are alright now. Maybe it could also work for someone else under Windows 7.
Post edited September 10, 2014 by Feamelwen
avatar
Feamelwen: Hi,
just wanted to share what worked for me. I also had the "rainbow colors" glitch, and so far, I mixed and tried almost every solution shared in these forums.

(I'm playing on a laptop under Windows 7 by the way.)

What did it was :

In the game properties :
- Windows 95 compatibility
- "run as administrator" checked
- nothing else checked in the game compatibility pannel
- the "-e" thingy added

- all programs (especially the explorers) closed from the task window
- only the "screen resolution" pannel left open when I launch the game (you can access the pannel from your desktop)

For the moment, that did it ... The colors are alright now. Maybe it could also work for someone else under Windows 7.
Thanks, it helped me get rid of the "rainbow colors" glitch.

I right-clicked the Sanitarium shorcut icon from my Desktop, Properties and under the Compatibility Tab I checked "Run this program in compatibility mode for": Windows 95.
I also checked "Run this program as an administrator".

I haven't done anything else.

Later edit: Everything works fine for me, I'm at the end of the 2nd Chapter.
Post edited 3 hours ago by GabiMoro