It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Dear GOG

I am quite disappointed in you. I bought Puddle today under the pretence that the game would work on Mac OS X 10.6.8 as it states on the game card page. Nevertheless, after i try to install the game, the game says that "This program needs Mac Os X 10.7 or later to work"

If this is the case, as it is on the STeam store page, why does the Gamecard page on GOG say that puddle works on 10.6.8? Can we work out something? I'm not THAT angry just a bit fustrated.
Please drop us a support ticket and we'll sort this out ASAP. This is obviously our mistake, and I apologize for any frustration this has caused.
I don't use a mac, but perhaps you can run the PC version in an emulator like wine? The game doesn't have high system requirements so it should run fine. Just a thought.
There's also a possible issue with the Windows requirements: '3D graphics card compatible with... OpenGL 2.1'. It won't run for me because, the error message says, I don't have OpenGL support for the framebuffer_object extension. That'll be owing to the not-stunningly-good Intel graphics chipset in my laptop, but the chipset is supposed to support OpenGL 2.1. According to http://www.opengl.org/wiki/Framebuffer_Object framebuffer objects didn't become core until version 3.0.

Mind you, I tried the OpenGL extensions viewer recommended to the OP of http://www.omnimaga.org/index.php?topic=15502.0 and it greys out GL_ARB_framebuffer_object but not GL_EXT_framebuffer_object. :-/ There are some developer comments in the Steam forum which suggest that Puddle just isn't very compatible with Intel chipsets, although those are supposed to pertain mainly to the Linux version.
I just purchased and installed the game, and I got the "framebuffer_object" error message, so the game will not start. I went to Nvidia's website and downloaded and installed the latest drivers compatible with my GeForce 8300GS (version 6.14.11.7824 from 10/7/2008) but still receive the error.

This game is not compatible with my computer, and I could not possibly have known that, given the listed system requirements.