It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Greetings from sunny Northern Ireland!
I downloaded this game today and installed it successfully (it passed the integrity check) but when I try and start it I get the following error:
Kingpin.exe has stopped working
A problem has caused the program to stop working.
Please close the program.
Screenshot
The first time I ran the game I got as far as the gold planet logo, and all subsequent attempts to run it never get beyond my screen changing its resolution.
I'm running Windows Vista Ultimate SP2 x64, fully updated. My graphics card drivers are the latest as of the date of this post [nVidia 8800GTX 768MB - driver version 195.62].
I've tried running the game in compatibility mode (XP SP2), as well as ticking some of the other compatibility options such as "Disable visual themes" and "Disable desktop composition", and I've tried running it normally and with "Run as administrator" to no avail. I've also tried disabling my anti-virus software which didn't help either.
Any ideas would be greatly appreciated! I'm itchin' to smite some punk-assed bitches with my trusty lead pipe.
Thank you kindly!
This question / problem has been solved by Ralackkimage
First try windows 98/me compatibility(games way older then XP) and disable visual themes, desktop composition and run as administrator.

If that doesn't work then someone in this thread may have figured it out.

http://www.gog.com/en/forum/Kingpin_Life_of_Crime/crashes_on_startup/perm=8/#p_b_8

and his link to the solution

http://www.nvnews.net/vbulletin/showthread.php?t=140452
Post edited June 06, 2011 by Funke
The nHancer method worked for me. Thank you!!
Kinda feel stupid that I didn't try it first.
avatar
Paddy: The nHancer method worked for me. Thank you!!
Kinda feel stupid that I didn't try it first.

No need to feel stupid unless you already knew about nhancer and the fact it would 100% fix your game and asked anyway :P. Of course this wouldn't be a problem if Nvidia didn't keep destroying compatibility with older games. I think all they had to do was include the open gl library file with the new drivers and it would still work fine.
We don't need nHancer anymore. Using the latest Nvidia drivers, go to "manage 3D parameters" - sorry if I mistranslated, I am using french drivers - and create custom program settings for kinpin.exe. Set the following value to ON: "extension limit". Now the game should launch without crashing.
Now that it is fixed, I can only hope for new drivers compatible with Omikron: The Nomad Soul and heaven will finally exist ;-)
avatar
UnF: We don't need nHancer anymore. Using the latest Nvidia drivers, go to "manage 3D parameters" - sorry if I mistranslated, I am using french drivers - and create custom program settings for kinpin.exe. Set the following value to ON: "extension limit". Now the game should launch without crashing.
Now that it is fixed, I can only hope for new drivers compatible with Omikron: The Nomad Soul and heaven will finally exist ;-)

I can verify with 100% certainty that this works with all Quake engine games, tested it with everything I had based of ID tech.
Ralackk is correct. You really do need nHancer. Simply enabling extension limit without setting a hex value disables all extensions. Sure it will let the game run but it will cripple OpenGL by limiting it to the v1.0 extensions. I have no idea if Kingpin is OpenGL v1.0 but why take the chance.
Here's something I copied from someone who knows this stuff better than I do:
(setting extension limit on) "effectively cripples OpenGL to the 1.0 extensions and thus results in the loss of Volumetric shadows, Dynamic Lighting, GLSL, NPOT, S3TC, Multi Texturing and FBOs (not counting other GL features)"
I have Kingpin and I'll be installing it soon and will do some testing. But I fully intend to use nHancer and set the extension limit value to 4844. That's the figure I used to make Call of Duty (#1) work before nVidia realized that they had to tweak the profiles (the early 190 series).
If anybody is interrested here is something else I got from that other forum. This is a list of values you can use in nHancer for OpenGL extension limit:
0 = limit off
1 = 15-21 extensions enabled. (1 is the equivalent of enabling GL EX Limit in nvcp)
11A8 = 106 extensions
1b58 = 130 extensions
4844 = 185 extensions
When I updated to nVidia's v197.45 and found that they now set the extension limit of old OpenGL games that they think are popular to 4844, such as Call of Duty. When I loaded Anachronox recently I had to set it manually to 4844. But they don't let you see any of that in the control panel.
Post edited May 19, 2010 by frankd3
Finally installed Kingpin.
After testing with extension limit just set to on in the nVidia control panel and then using nHancer to set the extension limit to value 4844, I can find no visible difference between the two for this game.
Post edited May 20, 2010 by frankd3
Okay, I'm getting the same thing, and I've got an ATI card. It used to run fine. This seems to have happened right after I installed the latest Catalyst drivers. And now Quake II and it's expansion packs are doing the same thing, prolly cause they use the same engine?
Post edited June 29, 2010 by predcon
Hey all,

I'm new to all this. Just downloaded kingpin as my first game and it wont work. I tried roght clicking and changing compatibility to windows 98/me and others and no luck. Also ran as administrator. Nothing.

I'm really disappointed with the outcome.

I'm using a Microsoft Surface Pro 3 i7 if that helps.

Thank you kindly!
avatar
SurfacePro3: [...] I'm using a Microsoft Surface Pro 3 i7 if that helps. [...]
I'd say it doesn't. By that I mean trying to run old 3D-games, a tablet is not very helpful.