It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Just wanted to poke my head in to say this app rules. I recently switched over full time to Debian, and this made life with my GOG collection a whole lot easier.

I've compiled the latest build and so far everything works great.

Thanks.
I just downloaded Don't Starve like this:

lgogdownloader --platform 4 --download --game dont_starve

But for some reason it didn't download the Reign of Giants expansion. Not sure how to specify it even.
avatar
shmerl: I just downloaded Don't Starve like this:

lgogdownloader --platform 4 --download --game dont_starve

But for some reason it didn't download the Reign of Giants expansion. Not sure how to specify it even.
Probably caused by bad dlc count information try with "--ignore-dlc-count dont_starve"
avatar
Sude: Probably caused by bad dlc count information try with "--ignore-dlc-count dont_starve"
OK, I checked out the master and run it like this:

lgogdownloader --platform 4 --download --ignore-dlc-count --game dont_starve

It tried to download all my games however.
Post edited June 21, 2015 by shmerl
avatar
shmerl: OK, I checked out the master and run it like this:

lgogdownloader --platform 4 --download --ignore-dlc-count --game dont_starve

It tried to download all my games however.
You forgot to give argument to --ignore-dlc-count which caused it to ignore --game option
This is now fixed in 9c80ed1 by implicitly setting the default value. It will now just ignore the option when no argument is given to it, though perhaps I should set it to ".*" when it is used.

Try: lgogdownloader --platform 4 --download --ignore-dlc-count dont_starve --game dont_starve
Post edited June 21, 2015 by Sude
avatar
Sude: Try: lgogdownloader --platform 4 --download --ignore-dlc-count dont_starve --game dont_starve
Thanks, it worked that way. I think in case where no parameter is provided it should just use what --game provides.
Post edited June 21, 2015 by shmerl
avatar
Sude: It will now just ignore the option when no argument is given to it, though perhaps I should set it to ".*" when it is used.
avatar
shmerl: I think in case where no parameter is provided it should just use --game provides.
Using by default the parameter provided to --game is what sounds the most intuitive to me.

By the way Sude, I think I didn’t thank you for lgogdownloader for a couple of weeks now (or might it be months?), so thank you again ;)

-----

Now that I think of it, wouldn’t the behaviour be exactly the same whether --ignore-dlc-count is set to .* or to the parameter given to --game?
Post edited June 21, 2015 by vv221
avatar
vv221: Now that I think of it, wouldn’t the behaviour be exactly the same whether --ignore-dlc-count is set to .* or to the parameter given to --game?
Not at the moment because the filtering is done in Downloader::getGameList after Downloader::getGames gets the DLC info. I'm going to move the filtering to Downloader::getGames so that --ignore-dlc-count .* applies only to parameter given to --game

edit: in 0f2268c filtering is now done in Downloader::getGames and ".*" is default for --ignore-dlc-count
Post edited June 21, 2015 by Sude
Since a few days I have to re-login every time I use lgogdownloader (error messge: "Line 1, Column 1 Syntax error: value, object or array expected."). It looks like GOG has reduced the lifetime of the token drastically. The re-login works as long as I only download a single game. Global download (i.e. without the --game option) does not work anymore, after a while I get a lot of HTTP ERROR: 500 messages, probably because the token has expired before lgogdownloader has finished its session.

Is there any way to keep the session active so that the token does not expire? If not, would it be possible to add an automatic re-login to lgogdownloader?
avatar
eiii: Since a few days I have to re-login every time I use lgogdownloader (error messge: "Line 1, Column 1 Syntax error: value, object or array expected."). It looks like GOG has reduced the lifetime of the token drastically. The re-login works as long as I only download a single game. Global download (i.e. without the --game option) does not work anymore, after a while I get a lot of HTTP ERROR: 500 messages, probably because the token has expired before lgogdownloader has finished its session.

Is there any way to keep the session active so that the token does not expire? If not, would it be possible to add an automatic re-login to lgogdownloader?
Interesting. I got that, but it only affected --download, not --download-file, so I made plans to finish switching my lgogd_uri GUI entirely to using the literal values of the gogdownloader:// URLs.

(Currently, it uses --download for games and patches as a holdover from the older site design without Linux gogdownloader:// URLs)
I'm not sure if this is already possible and I'm just too dumb to figure out how to do it via the platform priority system, but I want lgogdownloader to download

1) Windows & Linux, and
2) deb only if no tar.gz exists

1 isn't a problem at all, and 2 is roughly approximated by --no-deb, but for games that have no tar archive (e.g. Indiana Jones and the Fate of Atlantis) this results in no Linux version being downloaded at all. (Of course it'd be preferable if GOG were consistent and offered both deb and tar.gz for all games with a Linux version, there's no reason not to.)