It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
I've renamed the ddraw.dll and tried checking and unchecking that OS option for logitech mouse and neither options work. This is after installing the TeamX patch (1.3.5), NPC mod and last the resolution patch.

What should I do?

Damnit, I forgot to mention it's Fallout 1 I'm talking about in the title. If a moderator could add that I would appreciate it.

I had forgotten that the .exe was overwritten during that TeamX patch 1.2 (I don't know why there's 1.2 and 1.3.5 in the mod thread here but the latter didn't have a .exe) so I changed to the the GOG one and now the mouse was perfect but due to the change of name on ddraw.dll colours were weird. I changed that back and now the mouse is weird again. :(

If I use GOG's exe, checked OS option and ddraw.exe the mouse seems to be emulated as the original game meaning it's laggy but not as extreme as I had first. However, if I change the name of ddraw.dll the mouse is perfect, it's like a modern game without neither mouse acceleration or smoothing but the damn colours become like artifacts. Is there any way to avoid that?

Windows 7 64-bit if that changes anything.
Post edited February 17, 2013 by Nirth
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
Nirth: I've renamed the ddraw.dll and tried checking and unchecking that OS option for logitech mouse and neither options work. This is after installing the TeamX patch (1.3.5), NPC mod and last the resolution patch.

What should I do?

Damnit, I forgot to mention it's Fallout 1 I'm talking about in the title. If a moderator could add that I would appreciate it.

I had forgotten that the .exe was overwritten during that TeamX patch 1.2 (I don't know why there's 1.2 and 1.3.5 in the mod thread here but the latter didn't have a .exe) so I changed to the the GOG one and now the mouse was perfect but due to the change of name on ddraw.dll colours were weird. I changed that back and now the mouse is weird again. :(

If I use GOG's exe, checked OS option and ddraw.exe the mouse seems to be emulated as the original game meaning it's laggy but not as extreme as I had first. However, if I change the name of ddraw.dll the mouse is perfect, it's like a modern game without neither mouse acceleration or smoothing but the damn colours become like artifacts. Is there any way to avoid that?

Windows 7 64-bit if that changes anything.
Hey Nirth
Something I learned that helps me with some games, is following:
* Enter game like you always do.
* Return to desktop (alt+tab).
* Finish explorer.exe.
Now see if colors are normal.
Go to NMA-Fallout and download TeamX 1.2 and 1.3.5, then download missing children patch (if you want it) and also look for the high resolution pack, after you have installed them all, run the game, if the mouse lags, then exit the game and rename ddraw.dll and fire up the game again, see if it helps, if it doesnt help, delete it
Also start a fresh Fallout installation, not the one you installed these patches

Also under compatibility settings for all users run as administrator and set compatibilty to windows 95
Post edited February 25, 2013 by dewtech
Do you have a framelimiter enabled? If yes, disable it for the time playing or create a custom profile for Fallout. I limited my fps to 60 and had a very stuttery experience with both Fallout games until I finally found the culprit.
Post edited February 28, 2013 by Dead-End
avatar
Dead-End: Do you have a framelimiter enabled? If yes, disable it for the time playing or create a custom profile for Fallout. I limited my fps to 60 and had a very stuttery experience with both Fallout games until I finally found the culprit.
Small bump here because your solution seemed to have done it. The first time ever a frame limiter was the cause of my issue. The mouse, performance, stability all seems fine in DX9 mode now.

It does bother me though about frame rate issue, not sure it's going to be an issue during gameplay but it's possible it might become unvaried when many different animations move. It seems vertical sync causes the same issue as the frame limiter does too.