It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

I have just received Duke Nuke 3D for free form When I went to play it, it displays a completely green screen. I hear everything load fine, its just that the RBY(Red/Blue/Yellow) might be screwed up in the game. I have redownloaded it and I get the same problem. Here are my PC specs:

Win 7
8GB 1333Mhz RAM
Radeon HD 5670
untitled.png (148 Kb)
No posts in this topic were marked as the solution yet. If you can help, add your reply
you only need to disable some of your modern graphics card's fancy settings.
open your control centre and create an application profile for duke3d.exe
turn off everything or select application settings
and run the game

it worked for me about 15 mins ago :)

(hope my instructions are clear, i'm not super-technical)
Thanks for the answer, but I just found my own solution. Go into GOG Games\Duke Nukem 3D\ . Then go to Launch Graphic Mode Setup. I selected DDraw graphic mode at full screen, and it worked:) Also was able to change the controls to a more modern setup.